Bug 610860 - tigervnc freezes the gnome desktop
Summary: tigervnc freezes the gnome desktop
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
(Show other bugs)
Version: 13
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-02 15:54 UTC by Yi Zhang
Modified: 2013-12-09 01:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-17 18:09:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
used dmesg> dmesg.txt cmd (67.04 KB, text/plain)
2010-07-14 20:55 UTC, Yi Zhang
no flags Details
xorg.0.log, this should be the right one (334.63 KB, text/plain)
2010-07-14 20:57 UTC, Yi Zhang
no flags Details
machine freezes when openoffice starts up (125.76 KB, text/plain)
2010-09-14 21:52 UTC, Yi Zhang
no flags Details

Description Yi Zhang 2010-07-02 15:54:20 UTC
Description of problem:
I upgrade Fedora 13 this morning. After reboot, i click on tigervnc icon on my gonme-panel, and it freezes the whole gnome screen. Keyboard has no response at all. I reboot host again and tried vncview, it does the same thing. 

Version-Release number of selected component (if applicable): Fedora 13


How reproducible: always


Steps to Reproduce:
1. upgrade Fedora 13 to latest 
2. click on vnctiger icon (i tried to run vncview as well, same result)
  
Actual results: screen freeze, keyboard has no response, but i can ssh into host from another host


Additional info:
my laptop is lenovo t60 
[root@works4you ~]# uname -a
Linux <workstatation name> 2.6.33.5-124.fc13.x86_64 #1 SMP Fri Jun 11 09:38:12 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

I tried downgrade tigervnc 
(tigervnc-1.0.90-0.12.20100420svn4030.fc13.x86_64) to 
(tigervnc-1.0.90-0.8.20100219svn3993.fc13.x86_64), but I still get same problem

[root@works4you ~]# rpm -qa | grep tigervnc
tigervnc-server-1.0.90-0.12.20100420svn4030.fc13.x86_64
tigervnc-1.0.90-0.8.20100219svn3993.fc13.x86_64

Comment 1 Adam Tkac 2010-07-14 07:26:33 UTC
This is weird, it seems like a graphics driver issue than vncviewer issue. Would it be possible to attach dmesg output and /var/log/Xorg.0.log, please?

Can you please ssh into frozen machine and check if Xorg process simply hangs or if it consumes 100% CPU time? Thank you in advance.

Comment 2 Yi Zhang 2010-07-14 20:55:43 UTC
Created attachment 431895 [details]
used dmesg> dmesg.txt cmd

Comment 3 Yi Zhang 2010-07-14 20:57:55 UTC
Created attachment 431896 [details]
xorg.0.log, this should be the right one

Comment 4 Adam Tkac 2010-07-22 10:05:24 UTC
This really seems like graphics driver issue for me. Reassigning to nouveau driver for further inspection.

Comment 5 Yi Zhang 2010-09-14 21:52:24 UTC
Created attachment 447333 [details]
machine freezes when openoffice starts up

Comment 7 Yi Zhang 2010-09-17 18:09:40 UTC
I tried update my video driver this morning, and the problem seems gone.

I disabled "nouveau" driver and installed the one from nVidia. After reboot, I don't see the freezes anymore. 

Thanks for the hint. I am pretty sure this is video driver related problem

I will close the bug. 

Yi Zhang


Note You need to log in before you can comment on or make changes to this bug.