Bug 610876 - be able to have ant recipe specify URL based bundle files
be able to have ant recipe specify URL based bundle files
Status: CLOSED DUPLICATE of bug 609154
Product: RHQ Project
Classification: Other
Component: Provisioning (Show other bugs)
3.0.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 12:24 EDT by John Mazzitelli
Modified: 2010-12-13 13:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 13:12:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2010-07-02 12:24:04 EDT
some ant recipe's might not want bundle files stored in RHQ uploaded by a user. There might be bundle files that already exist in a user's existing infrastructure (like a apache server or a code repository) accessible via a URL.

Be able to specify in the recipe archive and raw files that come from a URL. Be able to have ${var} notation in the URL.

example:

<rhq:deployment-unit>
    <rhq:url-file url="http://foo/${user.config.prop}.properties"
                  destinationFile="subdir/${user.config.prop}.properties"
                  replace="true"/> 
    <rhq:url-archive url="http://${server.host.prop}/file.zip">
    ...

Notice that <rhq:url-file> has the same semantics as <rhq:file> - with the name attribute replaced with a "url" attribute - it just gets the content of the file from the URL rather than the local disk at ${basedir}.

Notice that <rhq:url-archive> has the same semantics as <rhq:archive> - with the name attribute replaced with a "url" attribute - it just gets the content of the archive from the URL rather than the local disk at ${basedir}.

An optional further enhancement would be to support credentials of the URL is secured.
Comment 1 John Mazzitelli 2010-07-02 12:30:15 EDT
bumping to medium priority - this would be a helpful feature
Comment 2 John Mazzitelli 2010-07-02 12:36:25 EDT
side note: I would like to add url-type commands to the file template bundle type's recipe as well.
Comment 3 Corey Welton 2010-09-28 08:54:10 EDT
Triaged 24-Sept
Comment 4 John Mazzitelli 2010-12-13 13:12:39 EST

*** This bug has been marked as a duplicate of bug 609154 ***

Note You need to log in before you can comment on or make changes to this bug.