This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 610879 - ant bundle distro file has a raw file but GUI still wants me to upload it
ant bundle distro file has a raw file but GUI still wants me to upload it
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Provisioning (Show other bugs)
3.0.0
All All
high Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: rhq4
  Show dependency treegraph
 
Reported: 2010-07-02 12:32 EDT by John Mazzitelli
Modified: 2011-05-23 21:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
testbundle.zip (603 bytes, application/zip)
2010-12-23 11:12 EST, John Mazzitelli
no flags Details

  None (edit)
Description John Mazzitelli 2010-07-02 12:32:45 EDT
I have my bundle distribution file which contains 2 entries. 1. deploy.xml and 2. subdir/test.properties

I am trying to upload this bundle distribution .zip file using the GUI.

It doesn't realize that subdir/test.properties exists in the bundle distro zip and its asking to upload it.

Need to fix the server-side ant bundle plugin so it doesn't report that it needs the file if it already exists in the bundle distro zip file.
Comment 1 Shashin Shinde 2010-07-02 12:39:50 EDT
I think in this case the problem is with the subdir/test.properties
If the file is present at the same level as deploy.xml file in my-bundle.zip the UI finds it correctly. If it is in some child directory, it is not found by the UI. Running it from the command line rhq-ant works fine.
Comment 2 John Mazzitelli 2010-12-23 11:11:04 EST
git commit 9f1a09b854b0f21b66819f2906e7b6659347d2e7
Comment 3 John Mazzitelli 2010-12-23 11:12:17 EST
Created attachment 470446 [details]
testbundle.zip

to test, if you can upload the attached "testbundle.zip" bundle distribution file to the RHQ server and a bundle is successfully created without it asking you to upload additional files, this bug is fixed.
Comment 4 Sunil Kondkar 2011-03-09 05:42:56 EST
Verified on Build# 1083 ( Version: 4.0.0-SNAPSHOT Build Number: fbbf83c)

Uploaded the attached "testbundle.zip" bundle distribution file to the RHQ server. The bundle is successfully created without asking to upload additional files.

Marking the bug as verified.
Comment 5 Corey Welton 2011-05-23 21:12:58 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:12:58 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 7 Corey Welton 2011-05-23 21:13:08 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.