Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 610955 - Spacewalk proxy does not function, crashes with anaconda
Spacewalk proxy does not function, crashes with anaconda
Status: CLOSED NEXTRELEASE
Product: Spacewalk
Classification: Community
Component: Proxy Server (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
:
Depends On:
Blocks: space12
  Show dependency treegraph
 
Reported: 2010-07-02 17:04 EDT by Micro-Shock
Modified: 2010-09-20 14:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-20 14:10:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Micro-Shock 2010-07-02 17:04:05 EDT
Description of problem:
kick starting client through the proxy server causes Anaconda to report: " File .... cannot be opened.  This is due to a missing file, or corrupt package, or corrupt media.  please verify your installation source." using wget to retrieve the file does work just fine. fails on the very first rpm package

Rolling spacewalk-proxy back to 0.8 and everything works as expected.

Version-Release number of selected component (if applicable):
1.0

How reproducible:
kick start client through spacewalk proxy server

Steps to Reproduce:
1. booted unit off USB stick with kickstart part of url 
2. system brings down the kickstart file as well as everything up to stage2.img
3. system does not bring down any rpm files
  
Actual results:
kickstart fail

Expected results:
kickstart working

Additional info:
Comment 1 Justin Sherrill 2010-07-02 17:08:41 EDT
Also described here:

http://www.mail-archive.com/spacewalk-list@redhat.com/msg04856.html
Comment 2 Micro-Shock 2010-09-20 14:10:01 EDT
Justin Sherrill has solved this issue.

Note You need to log in before you can comment on or make changes to this bug.