Bug 610966 - Brightness keys do not work on Lenovo W510
Brightness keys do not work on Lenovo W510
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hal-info (Show other bugs)
6.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 17:57 EDT by David Kovalsky
Modified: 2017-12-06 06:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 06:07:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (50.81 KB, text/plain)
2010-07-02 17:58 EDT, David Kovalsky
no flags Details
xev screenshot (1.38 MB, image/jpeg)
2010-08-19 09:06 EDT, David Kovalsky
no flags Details
gnome-power-manager --verbose output (15.29 KB, text/plain)
2010-12-15 11:08 EST, David Kovalsky
no flags Details

  None (edit)
Description David Kovalsky 2010-07-02 17:57:47 EDT
Not 100% sure if this is xorg-x11-server thing, let's start here. 

I'm Lenovo W510 I'm able to adjust the LCD brightness on RHEL5 via the hardware keys, but not on RHEL6. When I press the FN+brightness key the brightness indicator pops up, but nothing changes. 

I tried using gnome brightness applet and that is working. 

Nothing interesting in the logs is shown. 

kernel-2.6.32-37.el6.x86_64
xorg-x11-server-Xorg-1.7.7-16.el6.x86_64
xorg-x11-drv-nouveau-0.0.16-8.20100423git13c1043.el6.x86_64
Comment 1 David Kovalsky 2010-07-02 17:58:24 EDT
Created attachment 429177 [details]
/var/log/Xorg.0.log
Comment 2 Dave Airlie 2010-07-05 18:41:07 EDT
nvidia gpu, transfer to nouveau.
Comment 3 Ben Skeggs 2010-07-05 23:19:06 EDT
Can you list the contents of /sys/class/backlight for me please.
Comment 4 David Kovalsky 2010-07-08 06:38:14 EDT
Hi Ben, 
here you go:

[root@kovinek ~]# ls -lR /sys/class/backlight/
/sys/class/backlight/:
total 0
lrwxrwxrwx. 1 root root 0 Jul  8 12:06 acpi_video0 -> ../../devices/virtual/backlight/acpi_video0
lrwxrwxrwx. 1 root root 0 Jul  8 12:05 nv_backlight -> ../../devices/pci0000:00/0000:00:03.0/0000:01:00.0/backlight/nv_backlight
lrwxrwxrwx. 1 root root 0 Jul  8 12:10 thinkpad_screen -> ../../devices/virtual/backlight/thinkpad_screen
Comment 5 RHEL Product and Program Management 2010-07-15 11:11:38 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 6 David Kovalsky 2010-08-12 03:55:49 EDT
Just FYI - brightness keys work properly on F13

xorg-x11-drv-nouveau-0.0.16-7.20100423git13c1043.fc13.x86_64
kernel-2.6.33.6-147.2.4.fc13.x86_64
Comment 7 Ben Skeggs 2010-08-12 07:46:26 EDT
As the brightness applet is working, it doesn't appear the hw control is at fault.  It's probably a problem of getting the brightness keypress through the stack.

I'm not 100% sure who's responsible for this, reassigned to Peter as he may.
Comment 8 Peter Hutterer 2010-08-12 21:48:00 EDT
please switch to runlevel 3, then start X with "xinit --". This will bring up X and an xterm. In that xterm, run xev and test if you see any events when you hit the brightness buttons. 

This will help us narrow down whether it is an issue in X or in the desktop stack.
Comment 9 David Kovalsky 2010-08-19 09:05:40 EDT
Yup, events are shown (attaching screenshot).
Comment 10 David Kovalsky 2010-08-19 09:06:46 EDT
Created attachment 439680 [details]
xev screenshot
Comment 11 Peter Hutterer 2010-08-19 19:02:01 EDT
reassigning to g-s-d, the key events are delivered.
Comment 12 Bastien Nocera 2010-08-20 06:23:48 EDT
gnome-settings-daemon doesn't touch the brightness, only gnome-power-manager handles them.
Comment 13 Corey Ashford 2010-11-12 03:45:46 EST
I'm seeing this problem on Fedora 14 on a W510 as well.
Comment 14 Richard Hughes 2010-11-30 14:01:58 EST
David, can you please attach the output for:

killall gnome-power-manager
gnome-power-manager --verbose

And then pressing the brightness buttons a few times. Thanks.
Comment 15 David Kovalsky 2010-12-15 11:08:37 EST
Created attachment 468882 [details]
gnome-power-manager --verbose output

Hi Richard, 

attaching the log. I've pressed brightness-down key twice, brightness-up key twice. Then CTRL+C to quit.
Comment 18 RHEL Product and Program Management 2011-07-05 20:45:21 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 20 Richard Hughes 2014-05-20 04:55:32 EDT
The issue here is that laptop_panel.brightness_in_hardware is set, i.e. HAL has told gnome-power-manager that the hardware is handling it's own brightness control. This was probably true before nouveau started handling the backlight device. So, the real fix is to fix hal-info to not set this key for the specified hardware now nouveau is new enough to do the right thing.
Comment 21 Jan Kurik 2017-12-06 06:07:26 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.