Bug 610976 - unable to burn dual layer DVD+R
Summary: unable to burn dual layer DVD+R
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: k3b
Version: 13
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-02 22:35 UTC by Tom Horsley
Modified: 2011-05-01 20:57 UTC (History)
11 users (show)

Fixed In Version: k3b-2.0.2-4.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-01 20:56:45 UTC


Attachments (Terms of Use)
screenshot of burn dialog (50.11 KB, image/png)
2011-03-29 17:48 UTC, Tom Horsley
no flags Details
screenshot k3b 2.0.2-2.fc14.i686 (55.66 KB, image/png)
2011-03-29 17:55 UTC, Jorge García
no flags Details

Description Tom Horsley 2010-07-02 22:35:24 UTC
Description of problem:

Previous versions of k3b automatically chose growisofs when writing a dual layer
DVD+R. The version releases with fedora 13 seems to always default to using
wodim for all writing, but unfortunately wodim doesn't seem to work on dual
layer DVD+R (at least not with the combination of media and drive I have).

I finally found the option in the burn dialog to select which program to use
and discovered that growisofs works perfectly with the same media and drive
where wodim always fails.

Since older k3b versions apparently chose growisofs automatically, this seems
like a regression.

Version-Release number of selected component (if applicable):
k3b-1.92.0-1.fc13.x86_64
wodim-1.1.10-1.fc13.x86_64
dvd+rw-tools-7.1-4.fc12.x86_64


How reproducible:

I burned 3 coasters trying different speeds and options till I found the
option to use growisofs. The failures were all the same, the write would
stop working at about 1 gig worth of data and give obscure errors messages
about having no permission to access device.


Steps to Reproduce:
1.use k3b with default options to write 8 gig to a DVD+R DL disk
2.watch it fail at about 1 gig.
3.
  
Actual results:
coaster

Expected results:
backed up data I can verify against the originals.

Additional info:
The media I'm using is 8x TDK DVD+R DL (which is identified by k3b as actually
being ritek media).

The drive I'm using is a Pioneer DVR-117D

I always get the failure with the TDK media. I was able to write a Verbatim
DVD+R DL disk, but wodim decided for some reason that it has to write
at 2.4X rather than the 8X the Verbatim media is supposedly rated at.

Comment 1 Tom Horsley 2010-07-03 00:06:43 UTC
Here's what dvd+rw-mediainfo has to say about the TDK media:

zooty> dvd+rw-mediainfo /dev/sr0
INQUIRY:                [PIONEER ][DVD-RW  DVR-117D][1.07]
GET [CURRENT] CONFIGURATION:
 Mounted Media:         2Bh, DVD+R Double Layer
 Media ID:              RITEK/S04
 Current Write Speed:   8.0x1385=11080KB/s
 Write Speed #0:        8.0x1385=11080KB/s
 Write Speed #1:        6.0x1385=8310KB/s
 Write Speed #2:        4.0x1385=5540KB/s
 Write Speed #3:        2.4x1385=3324KB/s
 Speed Descriptor#0:    00/4173823 R@8.0x1385=11080KB/s W@8.0x1385=11080KB/s
 Speed Descriptor#1:    00/4173823 R@6.0x1385=8310KB/s W@6.0x1385=8310KB/s
 Speed Descriptor#2:    00/4173823 R@4.0x1385=5540KB/s W@4.0x1385=5540KB/s
 Speed Descriptor#3:    00/4173823 R@2.4x1385=3324KB/s W@2.4x1385=3324KB/s
READ DVD STRUCTURE[#0h]:
 Media Book Type:       00h, DVD-ROM book [revision 0]
 Legacy lead-out at:    2086912*2KB=4273995776
DVD+R DOUBLE LAYER BOUNDARY INFORMATION:
 L0 Data Zone Capacity: 2086912*2KB, can still be set
READ DISC INFORMATION:
 Disc status:           blank
 Number of Sessions:    1
 State of Last Session: empty
 "Next" Track:          1
 Number of Tracks:      1
READ TRACK INFORMATION[#1]:
 Track State:           blank
 Track Start Address:   0*2KB
 Next Writable Address: 0*2KB
 Free Blocks:           4173824*2KB
 Track Size:            4173824*2KB
 ROM Compatibility LBA: 242432
READ CAPACITY:          0*2048=0

Comment 2 Rex Dieter 2011-01-16 23:26:03 UTC
Looks like we can consider switching to using growisofs by default then.  any objections?

Comment 3 Kevin Kofler 2011-01-19 18:05:48 UTC
As discussed on IRC: no objections from me, in fact I have been complaining about wodim getting used by default ever since I first noticed it (even though it did work for me). Wodim's DVD support is known to be bad, DVDs are what growisofs is for.

Comment 4 Tom Horsley 2011-01-19 18:54:37 UTC
I've never tried growisofs on CDs. It might be just as bad as wodim is on
DVDs :-). The previous behavior of k3b was to select wodim for CDs and
growisofs for DVDs by default.

Comment 5 Kevin Kofler 2011-01-19 19:12:00 UTC
AFAIK, growisofs doesn't support CDs at all, only DVDs and BluRay discs.

K3b 1 always used cdrecord/wodim for CDs and growisofs for DVDs, it didn't even SUPPORT using wodim for DVDs. That feature was added by somebody using Jörg Schilling's new cdrecord with the built-in ProDVD code, but we (and wodim upstream) aren't shipping that code for licensing reasons (it's under the CDDL (previous versions were entirely proprietary, so we can't fork an old version either), other code it's linked to is GPLed, making the combination undistributable). What is shipped in wodim is an ancient experimental community-contributed DVD support patch for cdrecord (from the times where ProDVD was entirely proprietary). So it's a bad idea to use wodim for DVDs.

We're now evaluating a K3b patch where it will refuse to use cdrecord for DVDs if cdrecord is actually wodim, choosing growisofs instead. So far we're asking upstream for feedback, but chances are high it will land at least in our K3b builds, and hopefully upstream too.

Comment 6 Fedora Update System 2011-01-20 14:32:03 UTC
k3b-2.0.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/k3b-2.0.2-2.fc14

Comment 7 Fedora Update System 2011-01-20 14:33:24 UTC
k3b-2.0.2-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/k3b-2.0.2-2.fc13

Comment 8 Fedora Update System 2011-01-20 19:53:40 UTC
k3b-2.0.2-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update k3b'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/k3b-2.0.2-2.fc14

Comment 9 Fedora Admin XMLRPC Client 2011-01-26 14:59:42 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 10 Fedora Update System 2011-01-31 19:56:28 UTC
k3b-2.0.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-01-31 19:56:51 UTC
k3b-2.0.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Account closed by user 2011-03-25 00:20:09 UTC
(In reply to comment #5)

> undistributable). What is shipped in wodim is an ancient experimental
> community-contributed DVD support patch for cdrecord (from the times where
> ProDVD was entirely proprietary). So it's a bad idea to use wodim for DVDs.

http://cdrecord.berlios.de/private/linux-dist.html#problems

Comment 13 Kevin Kofler 2011-03-25 00:50:14 UTC
Why are you posting that link? I know that page all too well.

It is true that the wodim DVD support is of poor quality, and this is exactly why we now default K3b to growisofs.

However, unfortunately, Jörg Schilling's views of licensing are somewhat "original" and, in particular, not shared by Red Hat Legal. And the decisions of what is shippable in Fedora are taken by Red Hat Legal, not by Jörg Schilling. I also think a company's legal department is more likely to be right on legal questions than an individual developer.

This bug has also been resolved for 3 months, so your posting that link is of no help whatsoever.

Comment 14 Kevin Kofler 2011-03-25 00:51:02 UTC
Sorry, the bug has been resolved for 2 months, not 3 months. :-) But that doesn't make your comment any less off topic.

Comment 15 Tom Horsley 2011-03-25 09:30:14 UTC
I'm running k3b-2.0.2-2.fc14.x86_64, and when I neglected to explicitly choose growisofs just the other day when attempting to backup about 7.9 gig of files to a double sided DVD+R disk, k3b once again decided to use wodim and generated another coaster, so the bug don't look resolved to me.

Comment 16 Tom Horsley 2011-03-25 09:33:25 UTC
Make that dual layer, not double sided.

Comment 17 Jorge García 2011-03-29 15:39:30 UTC
Hello, 

I'm using Fedora 14 and k3b-2.0.2-2.fc14.i686 and still uses wodim.

How can  I change this setting to growisofs?

Comment 18 Tom Horsley 2011-03-29 17:05:02 UTC
Don't know any way to make it stick permanently, but if you look close once you bring up the burn dialog there is a pull down menu for "burning app" which normally defaults to "auto", but you can change to explicitly select growisofs.
(Assuming you have growisofs installed).

Comment 19 Jorge García 2011-03-29 17:17:41 UTC
Hi Tom, I dont see anything like "burning app" on burn dialog, just image type, burn medium, speed, writing mode, data mode, copies and others but not burning app.

Is there a way to change in settings / setup external programs?

Thanks.

Comment 20 Tom Horsley 2011-03-29 17:48:33 UTC
Created attachment 488511 [details]
screenshot of burn dialog

Here's what I see when burning a data DVD. I guess it is called "Writing app", not "burning app". I've highlighted it in red in the screenshot.

Comment 21 Jorge García 2011-03-29 17:55:21 UTC
Created attachment 488514 [details]
screenshot k3b 2.0.2-2.fc14.i686

Tom, this is mine, no option here.

Are you sure you are using 2.0.2-2?

Comment 22 Jorge García 2011-03-29 18:56:49 UTC
Aparently using wodim with sudo works fine with just one error:

"session fixation error"

command:
sudo wodim speed=3 -dao dev=/dev/sr1 file.iso

Comment 23 Tom Horsley 2011-03-29 19:20:56 UTC
zooty> rpm -q k3b
k3b-2.0.2-2.fc14.x86_64

Sure looks like it :-).

I also have this:

zooty> rpm -q -f /usr/bin/growisofs
dvd+rw-tools-7.1-5.fc14.x86_64

which is where /usr/bin/growisofs comes from. Maybe you don't have that
installed, so k3b doesn't bother providing the choice? That's the only
thing I can think of.

Comment 24 Jorge García 2011-03-29 19:38:00 UTC
Yes, I have the same:

k3b-common-2.0.2-2.fc14.noarch
k3b-libs-2.0.2-2.fc14.i686
k3b-2.0.2-2.fc14.i686
dvd+rw-tools-7.1-5.fc14.i686

strange thing...

Comment 25 Kevin Kofler 2011-04-23 00:40:02 UTC
Looks like in addition to k3bmetawriter.cpp, I also need to patch k3bdvdcopyjob.cpp and k3bdatajob.cpp, which for some reason have their own idea of the writing app to use.

This doesn't affect ISO burning (k3biso9660imagewritingjob.cpp delegates the choice of writing app to the MetaWriter), so if the patch was tested with ISO burning, that'd be why it passed testing.

Comment 26 Fedora Update System 2011-04-23 01:35:17 UTC
k3b-2.0.2-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/k3b-2.0.2-4.fc15

Comment 27 Fedora Update System 2011-04-23 01:35:49 UTC
k3b-2.0.2-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/k3b-2.0.2-4.fc14

Comment 28 Fedora Update System 2011-04-23 01:36:15 UTC
k3b-2.0.2-4.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/k3b-2.0.2-4.fc13

Comment 29 Kevin Kofler 2011-04-23 13:49:59 UTC
I submitted the patch upstream: https://git.reviewboard.kde.org/r/101208/

Comment 30 Fedora Update System 2011-04-23 20:50:18 UTC
Package k3b-2.0.2-4.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing k3b-2.0.2-4.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/k3b-2.0.2-4.fc14
then log in and leave karma (feedback).

Comment 31 Account closed by user 2011-04-23 21:12:30 UTC
(In reply to comment #13)

> Why are you posting that link? I know that page all too well.

Because no one explains the real problems of cdrkit/wodim. That page does it.
You? How about other people ?

> However, unfortunately, Jörg Schilling's views of licensing are somewhat
> "original" and, in particular, not shared by Red Hat Legal. And the decisions
> of what is shippable in Fedora are taken by Red Hat Legal, not by Jörg
> Schilling. I also think a company's legal department is more likely to be right
> on legal questions than an individual developer.

Irrelevant, nobody talked about cdrecord.

-thanks-

Comment 32 Kevin Kofler 2011-04-23 21:27:09 UTC
I already explained the issue which is relevant to THIS bug (the fact that wodim is using the old experimental community DVD patch due to licensing conflicts with the new ProDVD code by Jörg Schilling) as completely and objectively as I could in the comment #5 you originally replied to. Posting that link to an already-closed bug report wasn't helpful. (The information in Tom Horsley's comment #15 that the bug wasn't fixed properly was helpful, though. This, too, should be fixed now.)

IMHO, wodim should just drop DVD support entirely, or maybe execv growisofs for it.

Comment 33 Rodrigo de Farias Gomes 2011-04-23 23:14:30 UTC
(In reply to comment #19)
> Hi Tom, I dont see anything like "burning app" on burn dialog, just image type,
> burn medium, speed, writing mode, data mode, copies and others but not burning
> app.
> 
> Is there a way to change in settings / setup external programs?
> 
> Thanks.

Go to Settings -> Configure K3B -> Advanced and check the option "Show advanced GUI elements". Work for me :-)

Comment 34 Kevin Kofler 2011-04-26 02:55:27 UTC
So, has anybody tried the k3b-2.0.2-4.fc1[3456] builds in updates-testing yet? They should be selecting growisofs automatically, without having to manually select it.

Comment 35 Fedora Update System 2011-04-27 02:39:56 UTC
k3b-2.0.2-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 36 Fedora Update System 2011-05-01 20:56:37 UTC
k3b-2.0.2-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 37 Fedora Update System 2011-05-01 20:57:10 UTC
k3b-2.0.2-4.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.