This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 61098 - Too many gnome requirements
Too many gnome requirements
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 11:02 EST by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-04 15:40:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2002-03-13 11:02:50 EST
Description of Problem:
Installing redhat-config-network requires to install virtually all gnome
libraries, including even gnome-core.

The panel applet should move to a separate package to avoid this.

Version-Release number of selected component (if applicable):
0.9.13-1

How Reproducible:
100%

Steps to Reproduce:
1. Try to install the package on a KDE workstation without installing 20 GB
worth of gnome stuff you don't want to use

Actual Results:
Fails

Expected Results:
Base config tools shouldn't require all gnome libs, and definitely not gnome-core
Comment 1 Trond Eivind Glomsrxd 2002-03-28 15:40:03 EST
There has been a hard package freeze the last couple of weeks... not fixable.
Comment 2 Bernhard Rosenkraenzer 2002-04-03 07:43:53 EST
Suggested fix until the package can be split: 
 
AutoReqProv: no 
 
Gnome users will get the panel applet, KDE users will get the file with a couple of 
unresolved symbols, which doesn't matter, since it doesn't work outside of gnome anyway, 
so nobody will run it in KDE. 
 
Having a base tool depend on gnome-core which in turn depends on sawfish, which in turn 
depends on rep, rep-gtk, guile and other stuff no KDE user will touch is not acceptable.
Comment 3 Trond Eivind Glomsrxd 2002-04-04 15:34:31 EST
Dropping all dependencies to avoid a couple of libraries when using the
secondary desktop seems like a bad idea.
Comment 4 Bernhard Rosenkraenzer 2002-04-04 15:39:57 EST
Then make it

AutoReqprov: no
Requires: initscripts >= 5.99 usermode alchemist kudzu libglade pygtk-libglade
pygtk python pygnome-libglade pygnome libart_lgpl.so.2 ORBit gtk XFree86 zlib glibc

(The list is complete, I took it from rpm -qp --requires and just substracted
gnome-core and libpanel_applet.so.0, which this is about).

The broken dependency isn't just for one package, it's for one that drags along
dependencies on more than 10 others, and some of them are big.

Note You need to log in before you can comment on or make changes to this bug.