Bug 610983 - JBoss patch source access.redhat.com requests from support.redhat.com
Summary: JBoss patch source access.redhat.com requests from support.redhat.com
Status: CLOSED DEFERRED
Alias: None
Product: RHQ Project
Classification: Other
Component: Plugins   
(Show other bugs)
Version: 1.3.1
Hardware: All
OS: Linux
high
medium vote
Target Milestone: ---
: ---
Assignee: Simeon Pinder
QA Contact: Corey Welton
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: jon-sprint12-bugs 603787
TreeView+ depends on / blocked
 
Reported: 2010-07-02 23:26 UTC by Ondřej Žižka
Modified: 2010-07-07 13:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 13:55:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HTTP client log. (6.20 KB, text/plain)
2010-07-02 23:26 UTC, Ondřej Žižka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 607799 None None None Never

Description Ondřej Žižka 2010-07-02 23:26:22 UTC
Created attachment 429191 [details]
HTTP client log.

Not sure whether this is a duplicate of #607799.

When I create a JBoss patch source with the following URL, test and sync are OK;
but when I try to download a patch, JON sends requests to support.redhat.com.

See the attached log, which is also attached to #607799.

Comment 1 Ondřej Žižka 2010-07-02 23:30:47 UTC
Summary of the log: 

 >> "GET /jbossnetwork/secureDownload.html?softwareId=639 HTTP/1.1[\r][\n]"
 << "301 Location: https://access.redhat.com/home?softwareId=639
    ... 
 >> "GET /home?softwareId=639 HTTP/1.1[\r][\n]"
 << "<title>access.redhat.com | Welcome to the Red Hat Customer Portal </title>"
    ...

Comment 2 Charles Crouch 2010-07-06 13:22:38 UTC
Simeon
Didn't you see something similar once? Can you investigate?

Comment 3 Simeon Pinder 2010-07-06 13:50:07 UTC
I have seen something similar recently that seems related to caching of the old support.redhat.com host name. 

Because of a redirect problem that exists in
2.3.1(https://bugzilla.redhat.com/show_bug.cgi?id=607799), you should try the
following: 
i) delete the existing JBoss "Content Sources" and 
ii) the existing "Repository" 'Jboss Patches' feed and attempt to recreate both
Content Source(with access.redhat.com urls) again.
iii) For good measure, bounce the JON instance and with a fresh browser(to avoid potential caching), attempt your test again.

Comment 4 Simeon Pinder 2010-07-06 17:18:22 UTC
With a fresh 2.3.1 install, I hit https://bugzilla.redhat.com/show_bug.cgi?id=607799.  When I update the CSP url with :

https://access.redhat.com/jbossnetwork/restricted/feed/software.html?product=all&downloadType=all&flavor=rss&version=&jonVersion=2.0 

, I am able to test and synchronize csp feed successfully. 

Ondra, please confirm that this also resolves the situation for you.

Comment 5 Ondřej Žižka 2010-07-07 13:55:40 UTC
For the record, I was also able to test and synchronize. As I wrote in this bug description:

>> but when I try to download a patch, JON sends requests to support.redhat.com.

After I deleted sources and channels, created a new channel and source with access.redhat.com, I was able to apply CP03 patch. DEFFERED.


Note You need to log in before you can comment on or make changes to this bug.