Red Hat Bugzilla – Bug 610984
Please update to version >= 1.2.0
Last modified: 2010-07-13 17:09:26 EDT
Description of problem:
Curerntly gpgme is of version 1.1.8. This is heavily outdated, and currentl desktop encryption software like KDE's Kleopatra require at least a gpgme version equal or larger as 1.2.0. Without it, the S/MIME encryption does not work properly.
Version-Release number of selected component (if applicable):
Start Kleopatra, run self test, and you get a warning the gpgme is outdated and needs to be updated to properly contact the gpg-agent.
Steps to Reproduce:
1. Install Fedora and KDE.
2. Launch Kleopatra's self test.
3. Watch and sob.
Kleopatra cannot properly connect to gpg-agent.
It should work without a flaw.
GPGME is available in version 1.3.0 for over half a year. 1.2.0 is available for more than a year. There is no need to wait with the updates. Plus: cryptographic software should be handled with extra care, and updates should be done regularly to be on the safe side.
You sure Kleopatra's failed test(s) aren't just due to missing
In the meantime, I've prepped a gpgme-1.2.0 update, but will wait until after the holiday weekend to commit anything,
Hey Rex, no, I have everything installed:
$ rpm -qa|grep gnupg
Anyway, is there a *reason* why gpgme was kept on that old version?
no reason I'm aware of.
built for rawhide.