Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 610984 - Please update to version >= 1.2.0
Please update to version >= 1.2.0
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gpgme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
ftp://ftp.gnupg.org/gcrypt/gpgme/
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 19:29 EDT by Roland Wolters
Modified: 2010-07-13 17:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 17:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Roland Wolters 2010-07-02 19:29:00 EDT
Description of problem:
Curerntly gpgme is of version 1.1.8. This is heavily outdated, and currentl desktop encryption software like KDE's Kleopatra require at least a gpgme version equal or larger as 1.2.0. Without it, the S/MIME encryption does not work properly.

Version-Release number of selected component (if applicable):
1.1.8

How reproducible:
Start Kleopatra, run self test, and you get a warning the gpgme is outdated and needs to be updated to properly contact the gpg-agent.

Steps to Reproduce:
1. Install Fedora and KDE.
2. Launch Kleopatra's self test.
3. Watch and sob.
  
Actual results:
Kleopatra cannot properly connect to gpg-agent.

Expected results:
It should work without a flaw.

Additional info:
GPGME is available in version 1.3.0 for over half a year. 1.2.0 is available for more than a year. There is no need to wait with the updates. Plus: cryptographic software should be handled with extra care, and updates should be done regularly to be on the safe side.
Comment 1 Rex Dieter 2010-07-02 19:45:34 EDT
You sure Kleopatra's failed test(s) aren't just due to missing
gnupg2-smime
?
Comment 2 Rex Dieter 2010-07-02 19:54:41 EDT
In the meantime, I've prepped a gpgme-1.2.0 update, but will wait until after the holiday weekend to commit anything,
scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2291327
Comment 3 Roland Wolters 2010-07-02 20:35:38 EDT
Hey Rex, no, I have everything installed:
$ rpm -qa|grep gnupg
gnupg2-smime-2.0.14-2.fc13.x86_64
gnupg2-2.0.14-2.fc13.x86_64

Anyway, is there a *reason* why gpgme was kept on that old version?
Comment 4 Rex Dieter 2010-07-02 20:52:29 EDT
no reason I'm aware of.
Comment 5 Rex Dieter 2010-07-13 17:09:26 EDT
built for rawhide.

Note You need to log in before you can comment on or make changes to this bug.