Bug 611000 - Install of beta2 failed
Install of beta2 failed
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Chris Lumens
Release Test Team
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-02 22:21 EDT by Cia Watson
Modified: 2010-11-10 14:50 EST (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.59-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-10 14:50:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
copy of /tmp/anaconda-tb-* (188.90 KB, text/plain)
2010-07-06 12:47 EDT, Cia Watson
no flags Details
new /tmp/anaconda-tb-* (282.41 KB, text/plain)
2010-07-09 00:22 EDT, Cia Watson
no flags Details

  None (edit)
Description Cia Watson 2010-07-02 22:21:09 EDT
Description of problem:

First attempt at install failed after selecting language and keyboard (english, us) it started anaconda then my monitor said 'no signal' and the dvd was no longer being accessed BUT the HDD light was still coming on. Same result on my internal (somewhat flakey) dvd drive and external ASUS dvd drive. 

During the 2nd install attempt it got further, but said x startup failed, falling to text mode and after I selected the option of /dev/sda5 (replacing RHEL v6 beta1) it crashed again with a message 'Exception occurred' See below for output. 

Version-Release number of selected component (if applicable):
13.21.50

How reproducible:
?? I don't know if it's my system, Nvidia or other issues.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Install crashes moments after starting anaconda or get message of Exception occurred using basic video driver. 

Expected results:
Install of RHEL v6 is accomplished.

Additional info:

My system: AMD phenom 8650 triple core 2.3GHz, 2gb RAM
graphics: Nvidia GEForce 6150SE nForce 430
monitor: Acer x193W  1440x900 LCD
hard drive is a nearly new Seagate 500gb

On the install attempt using basic video driver, it had a message that X startup failed, falling to text mode. [ok] Then after I selected the install location of /dev/sda5 rather than the 'reinstall system' option, it brought up the 'Exception occurred' screen which said:
anaconda 13.21.50 exception report
Traceback (most recent call first):
File "/usr/lib/anaconda/text.py" line 595 in run (file, class names)=
StepToClasses [step]
File "/usr/bin/anaconda", line 1122, in <module>
anaconda.intf.run (anaconda) KeyError: 'cleardiskssel' 

with choices of [ok] [save] [debug] and when I selected save it had an option to submit a bug report which failed, with the message 'unable to file bug [Errno -3] Temporary failure in name resolution. [ok]
Comment 2 Chris Lumens 2010-07-06 09:01:07 EDT
Please attach the complete /tmp/anaconda-tb-* file to this bug report so I can see some more context on what you did.  THanks.
Comment 3 Cia Watson 2010-07-06 12:47:22 EDT
Created attachment 429830 [details]
copy of /tmp/anaconda-tb-*
Comment 4 Chris Lumens 2010-07-07 13:58:06 EDT
Does adding updates=http://clumens.fedorapeople.org/611000.img to your command line arguments fix this problem?
Comment 5 Cia Watson 2010-07-08 12:34:27 EDT
(In reply to comment #4)
> Does adding updates=http://clumens.fedorapeople.org/611000.img to your command
> line arguments fix this problem?    

I'll check tonight or tomorrow morning and get back to you. I'm guessing you mean editing the boot command line and adding that? (If so, no need to respond, if not then please clarify.)
Comment 6 Cia Watson 2010-07-09 00:22:10 EDT
Created attachment 430530 [details]
new /tmp/anaconda-tb-*

The short answer is 'no' the updates=command didn't fix this problem. The long answer is that the vesa boot got a little further along, still required a text install, and gave a message 'the following file systems for your Linux system were not unmounted cleanly. Please boot your Linux installation, let the file system be checked and shut down cleanly to upgrade  /dev/sda7 [ok]'

/dev/sda7 is a shared data partition, so I booted to Fedora 13, used the disk utility and unmounted it, then checked the fs and it came back after a few moments and said the file system is clean. 

I left it unmounted, rebooted and on the 2nd attempt with the updates= command it got past finding storage devices, to Installer detecting a GRUB bootloader on /dev/sda5 (location for the rhel v6 beta1 install and where I selected to install this), then I selected option to Update boot loader configuration, which brought up a new Exception occurred message.  The new /tmp/anaconda-tb-* is attached.
Comment 7 Brian Lane 2010-07-09 01:01:40 EDT
This second one looks like bad media or a bad optical drive to me. Did you run the media check and did it pass?
Comment 8 Cia Watson 2010-07-09 01:30:58 EDT
(In reply to comment #7)
> This second one looks like bad media or a bad optical drive to me. Did you run
> the media check and did it pass?    

In the 2nd paragraph I noted: 
I booted to Fedora 13, used the disk
utility and unmounted it, then checked the fs and it came back after a few
moments and said the file system is clean.

Same media and optical drive as the first one, though the drive is actually a bit suspect. It writes cd's fine but not dvd's, but the dvd was written on my external asus drive.  Please see next comment for an update.
Comment 9 Cia Watson 2010-07-09 02:12:55 EDT
Update:

I read the most recent attachment and it appeared it was using the fstab from the beta1 install on /dev/sda5. It showed sda3 as an ext3 partition; and ext3 is no longer ext3 but is now ZFS for Open Solaris. I edited the file and commented out that line, re-tried the install and while X wouldn't start again and it went to text install -- it appears to have installed or upgraded the beta1 install. 

It showed install of all 704 packages, and said it was updating install, and then a new 'Exception occurred'. That lead to filing a new bugzilla, see bug 612802.

I booted to the upgraded install, and as I was typing an update to this bugzilla the desktop froze, hard shutdown required. That may or may not lead to new issues. I'm typing this on my laptop.
Comment 10 Chris Lumens 2010-07-09 10:41:30 EDT
Yeah - the second traceback is definitely unrelated to the initial comment.  The initial comment is about a failure to skip the cleardisks UI in text mode, whereas the second traceback is media read errors that are probably nothing to do with anaconda.  Since you got to the reposetup steps, you're past where the cleardisks UI would try to appear.

I'm willing to declare victory over this bug.
Comment 11 Cia Watson 2010-07-09 11:07:48 EDT
Thanks. I wasn't given a reposetup step, probably since X wouldn't start. I used my external DVD to check the dvd media and it checked out fine, then re-did the vesa install request with the updates= option, and it skipped most of what it had done previously and went right to 'post upgrade configuration' and bootloader and Complete. 

I'm typing this from the beta2 desktop. So feel free to declare victory over this bug.
Comment 12 David Cantrell 2010-07-13 10:42:27 EDT
Closing per comments #10 and #11.
Comment 16 Chris Lumens 2010-07-16 10:06:47 EDT
Clearing needinfo.
Comment 18 Cia Watson 2010-07-23 01:03:18 EDT
fwiw, Fresh install (not an upgrade) of the 'refresh' of beta2 went without a hitch on this machine, gui install and everything.
Comment 19 Alexander Todorov 2010-07-23 06:50:46 EDT
Moving to VERIFIED per comment #18
Comment 20 releng-rhel@redhat.com 2010-11-10 14:50:17 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.