Bug 611007 - SELinux is preventing /usr/bin/kdm "execute" access on /sbin/mount.crypt.
Summary: SELinux is preventing /usr/bin/kdm "execute" access on /sbin/mount.crypt.
Status: CLOSED DUPLICATE of bug 599609
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: 13
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:9e8abcc3c39...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-03 03:39 UTC by Vladimir Monahov
Modified: 2010-07-07 10:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 10:51:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vladimir Monahov 2010-07-03 03:39:05 UTC
Summary:

SELinux is preventing /usr/bin/kdm "execute" access on /sbin/mount.crypt.

Detailed Description:

SELinux denied access requested by kdm. It is not expected that this access is
required by kdm and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:lvm_exec_t:s0
Target Objects                /sbin/mount.crypt [ file ]
Source                        kdm
Source Path                   /usr/bin/kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           kdm-4.4.4-2.fc13
Target RPM Packages           pam_mount-1.32-1.fc12
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686 #1
                              SMP Fri Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   4
First Seen                    Fri 02 Jul 2010 06:50:13 PM PDT
Last Seen                     Fri 02 Jul 2010 08:28:11 PM PDT
Local ID                      80bb5010-b825-405e-b8a0-1d2a1129acee
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278127691.985:15): avc:  denied  { execute } for  pid=1672 comm="kdm" name="mount.crypt" dev=dm-0 ino=61293 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lvm_exec_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1278127691.985:15): arch=40000003 syscall=11 success=no exit=-13 a0=bfe92e87 a1=99bf050 a2=99b54c8 a3=99b5f7a items=0 ppid=1578 pid=1672 auid=500 uid=0 gid=500 euid=0 suid=0 fsuid=0 egid=500 sgid=500 fsgid=500 tty=(none) ses=1 comm="kdm" exe="/usr/bin/kdm" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,kdm,xdm_t,lvm_exec_t,file,execute
audit2allow suggests:

#============= xdm_t ==============
allow xdm_t lvm_exec_t:file execute;

Comment 1 Miroslav Grepl 2010-07-07 10:51:52 UTC

*** This bug has been marked as a duplicate of bug 599609 ***


Note You need to log in before you can comment on or make changes to this bug.