Bug 61101 - paep driver won't load when the card is present
paep driver won't load when the card is present
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 11:21 EST by Nalin Dahyabhai
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-11 12:17:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2002-03-13 11:21:33 EST
Using kernel-smp-2.4.18-0.1, the paep driver won't load when there's an AEP SSL
Accelerator board present.

The relevant part of the lspci -v output:

00:03.0 Co-processor: Intel Corp.: Unknown device 1200 (rev 03) (prog-if 01)
        Subsystem: Unknown device 172a:0000
        Flags: bus master, medium devsel, latency 66, IRQ 5
        Memory at ec800000 (32-bit, prefetchable) [size=1M]
        I/O ports at 2000 [size=128]
        Memory at ee000000 (32-bit, prefetchable) [size=32M]
        Capabilities: [70] Power Management version 0

Running lspci with the -n flag:

00:03.0 Class 0b40: 8086:1200 (rev 03) (prog-if 01)
        Subsystem: 172a:0000
        Flags: bus master, medium devsel, latency 66, IRQ 5
        Memory at ec800000 (32-bit, prefetchable) [size=1M]
        I/O ports at 2000 [size=128]
        Memory at ee000000 (32-bit, prefetchable) [size=32M]
        Capabilities: [70] Power Management version 0
Comment 1 Nalin Dahyabhai 2002-03-13 11:25:50 EST
Almost forgot: the kernel message log:

AEP Device Driver. Version: UNLABELLED Build Date: Feb 27 2002
PCI AEP driver: Error: no devices (returning -ENODEV)

modprobe also complains that the driver has no license defined, while for the
most part it looks like a standard BSD-without-advertising license (the
statement at the top of driver_version.h is pretty scary, though).
Comment 2 Nalin Dahyabhai 2002-04-05 18:04:01 EST
Under 2.4.18-0.16smp, the driver loads, but applications will segfault when they
attempt to open the device.
Comment 3 Nalin Dahyabhai 2002-04-09 17:34:21 EDT
Works with kernel-2.4.18-0.18smp.  The driver doesn't check for invalid minor
numbers, and oopses instead of returning ENODEV, but that doesn't keep it from
working with the proper minors.
Comment 4 Arjan van de Ven 2002-04-10 04:51:37 EDT
any chance of getting that oops somewhere ?
The code appears to check...
Comment 5 Nalin Dahyabhai 2002-04-11 12:10:50 EDT
paep.c: line 576.  The exit_if_too_many_cards() macro just exits if the card
number is too high to be supported by the driver, not if it references a card
which isn't installed.
Comment 6 Nalin Dahyabhai 2002-04-11 12:17:54 EDT
Probably needs this inserted at line 574:

if (unit_no >= nb_cards)
    return -ENODEV;
Comment 7 Arjan van de Ven 2002-04-12 08:30:24 EDT
yup fixed

Note You need to log in before you can comment on or make changes to this bug.