Bug 611011 - [abrt] crash in gnumeric-1:1.10.0-1.fc13: excel_parse_name: Process /usr/bin/ssindex was killed by signal 11 (SIGSEGV)
[abrt] crash in gnumeric-1:1.10.0-1.fc13: excel_parse_name: Process /usr/bin/...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnumeric (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Huzaifa S. Sidhpurwala
Fedora Extras Quality Assurance
abrt_hash:48384784f18afcc70dcdf815e70...
:
: 626641 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-03 01:25 EDT by Donald Edward Winslow
Modified: 2010-09-11 15:17 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.10.9-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-11 15:17:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (18.62 KB, text/plain)
2010-07-03 01:25 EDT, Donald Edward Winslow
no flags Details

  None (edit)
Description Donald Edward Winslow 2010-07-03 01:25:50 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: ssindex -i /home/Donald/Documents/ecology/SOD/bayareaplots/SODmortality.xls
comment: I installed a large number of packages, but Gnumeric had been installed beforehand with no crashes. I rebooted, logged into Gnome, and started working. ABRT has announced two Gnumeric crashes in the last three hours. As it happens, I did use Gnumeric during this session, but one of the crashes was before I opened Gnumeric and the other crash was after I had closed Gnumeric. Something seems to be trying to index spreadsheets. I did install Beagle, but I uninstalled it after it started causing mono-core crashes ( I filed a bug report for that, too). I have not yet rebooted since I uninstalled Beagle, so maybe it's still working.
component: gnumeric
crash_function: excel_parse_name
executable: /usr/bin/ssindex
global_uuid: 48384784f18afcc70dcdf815e707dd00f2b5dfb8
kernel: 2.6.33.5-124.fc13.x86_64
package: gnumeric-1:1.10.0-1.fc13
rating: 4
reason: Process /usr/bin/ssindex was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. It seems to reproduce itself.
2.
3.
Comment 1 Donald Edward Winslow 2010-07-03 01:25:52 EDT
Created attachment 429224 [details]
File: backtrace
Comment 2 Julian Sikorski 2010-08-23 13:23:26 EDT
Gnumeric 1.10.9 is about to hit testing updates in a couple of days. Can you please retest if this is still a problem?
Comment 3 Donald Edward Winslow 2010-08-23 21:07:43 EDT
Yes, this is still an issue. I had not seen the bug since the day I found it, but in response to your query I tried reinstalling Beagle. Sure enough, after rebooting and working for a while, the crash happened again. I reported it and Bugzilla created a new bug: 626641.
Comment 4 Julian Sikorski 2010-08-24 05:09:41 EDT
*** Bug 626641 has been marked as a duplicate of this bug. ***
Comment 5 Julian Sikorski 2010-08-24 05:13:01 EDT
Sorry I was not specific enough. Please retest with gnumeric-1.10.9-1.fc13. It was pushed to testing today, you can install it with:
yum --enablerepo=updates-testing update gnumeric
you can also try new goffice too:
yum --enablerepo=updates-testing update goffice
Again, sorry for the confusion.
Comment 6 Donald Edward Winslow 2010-08-24 18:22:04 EDT
This morning I installed the gnumeric and goffice updates from the testing repository. I worked in Gnome for a while this morning, and then again this afternoon. This afternoon I used gnumeric to edit a spreadsheet. I did not see a crash at any point today. As far as I can tell, it's fixed!

Thanks,

Donald

Note You need to log in before you can comment on or make changes to this bug.