Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 611019 - SELinux is preventing /usr/bin/perl "connectto" access on /tmp/zmdc.sock.
SELinux is preventing /usr/bin/perl "connectto" access on /tmp/zmdc.sock.
Status: CLOSED DUPLICATE of bug 611016
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:7ca1bb933cd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-03 02:10 EDT by Bart Kus
Modified: 2010-07-04 17:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-04 17:35:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Kus 2010-07-03 02:10:53 EDT
Summary:

SELinux is preventing /usr/bin/perl "connectto" access on /tmp/zmdc.sock.  This happens
in F13 after /etc/php.ini is modified to set short_open_tag = On so that
zoneminder's /usr/share/zoneminder/www/includes/functions.php file does not
report a php parse error.  The package does not work otherwise.


Detailed Description:

SELinux denied access requested by zmdc.pl. It is not expected that this access
is required by zmdc.pl and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:httpd_t:s0
Target Context                unconfined_u:system_r:initrc_t:s0
Target Objects                /tmp/zmdc.sock [ unix_stream_socket ]
Source                        zmdc.pl
Source Path                   /usr/bin/perl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           perl-5.10.1-112.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686 #1 SMP
                              Fri Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Fri 02 Jul 2010 11:07:38 PM PDT
Last Seen                     Fri 02 Jul 2010 11:07:38 PM PDT
Local ID                      8dd4caa4-6482-4917-8a4f-824e7bc9476b
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278137258.784:27433): avc:  denied  { connectto } for  pid=3473 comm="zmdc.pl" path="/tmp/zmdc.sock" scontext=unconfined_u:system_r:httpd_t:s0 tcontext=unconfined_u:system_r:initrc_t:s0 tclass=unix_stream_socket

node=(removed) type=SYSCALL msg=audit(1278137258.784:27433): arch=40000003 syscall=102 success=no exit=-13 a0=3 a1=bfa7a4e0 a2=271d6c a3=9188008 items=0 ppid=2921 pid=3473 auid=500 uid=48 gid=488 euid=48 suid=48 fsuid=48 egid=488 sgid=488 fsgid=488 tty=(none) ses=1 comm="zmdc.pl" exe="/usr/bin/perl" subj=unconfined_u:system_r:httpd_t:s0 key=(null)



Hash String generated from  catchall,zmdc.pl,httpd_t,initrc_t,unix_stream_socket,connectto
audit2allow suggests:

#============= httpd_t ==============
#!!!! This avc is allowed in the current policy

allow httpd_t initrc_t:unix_stream_socket connectto;
Comment 1 Miroslav Grepl 2010-07-04 17:35:44 EDT

*** This bug has been marked as a duplicate of bug 611016 ***

Note You need to log in before you can comment on or make changes to this bug.