Bug 611031 - SELinux is preventing /usr/libexec/zoneminder/cgi-bin/nph-zms "associate" access .
SELinux is preventing /usr/libexec/zoneminder/cgi-bin/nph-zms "associate" acc...
Status: CLOSED DUPLICATE of bug 611016
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:adffe684393...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-03 02:54 EDT by Bart Kus
Modified: 2010-07-04 17:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-04 17:40:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Kus 2010-07-03 02:54:23 EDT
Summary:

SELinux is preventing /usr/libexec/zoneminder/cgi-bin/nph-zms "associate" access
.  Happens when trying to view video stream in zoneminder's web UI.

Detailed Description:

SELinux denied access requested by nph-zms. It is not expected that this access
is required by nph-zms and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:httpd_t:s0
Target Context                unconfined_u:system_r:initrc_t:s0
Target Objects                None [ shm ]
Source                        nph-zms
Source Path                   /usr/libexec/zoneminder/cgi-bin/nph-zms
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           zoneminder-1.24.2-4.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686 #1 SMP
                              Fri Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Fri 02 Jul 2010 11:53:41 PM PDT
Last Seen                     Fri 02 Jul 2010 11:53:41 PM PDT
Local ID                      ba497535-e86c-4373-9b3c-a70f1ef3d934
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278140021.450:27601): avc:  denied  { associate } for  pid=4655 comm="nph-zms" key=2053963777  scontext=unconfined_u:system_r:httpd_t:s0 tcontext=unconfined_u:system_r:initrc_t:s0 tclass=shm

node=(removed) type=SYSCALL msg=audit(1278140021.450:27601): arch=40000003 syscall=117 success=no exit=-13 a0=17 a1=7a6d0001 a2=8ca4a8 a3=3c0 items=0 ppid=2922 pid=4655 auid=500 uid=48 gid=488 euid=48 suid=48 fsuid=48 egid=488 sgid=488 fsgid=488 tty=(none) ses=1 comm="nph-zms" exe="/usr/libexec/zoneminder/cgi-bin/nph-zms" subj=unconfined_u:system_r:httpd_t:s0 key=(null)



Hash String generated from  catchall,nph-zms,httpd_t,initrc_t,shm,associate
audit2allow suggests:

#============= httpd_t ==============
allow httpd_t initrc_t:shm associate;
Comment 1 Miroslav Grepl 2010-07-04 17:40:36 EDT

*** This bug has been marked as a duplicate of bug 611016 ***

Note You need to log in before you can comment on or make changes to this bug.