Bug 611032 - SELinux is preventing /usr/libexec/zoneminder/cgi-bin/nph-zms "read write" access .
SELinux is preventing /usr/libexec/zoneminder/cgi-bin/nph-zms "read write" ac...
Status: CLOSED DUPLICATE of bug 611016
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:313938ce9eb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-03 02:58 EDT by Bart Kus
Modified: 2010-07-04 17:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-04 17:42:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Kus 2010-07-03 02:58:53 EDT
Summary:

SELinux is preventing /usr/libexec/zoneminder/cgi-bin/nph-zms "read write"
access .  Happens when trying to view video stream in zoneminder's web UI.  Coincides with the following crashes in /var/log/messages:

Jul  2 23:57:02 cctv setroubleshoot: SELinux is preventing /usr/libexec/zoneminder/cgi-bin/nph-zms "read write" access . For complete SELinux messages. run sealert -l b4983058-51fb-4c46-8440-1048ebbdc677
Jul  2 23:57:10 cctv zmdc[4778]: INF [Starting pending process, zmfilter.pl]
Jul  2 23:57:10 cctv zmdc[4778]: INF ['zmfilter.pl' starting at 10/07/02 23:57:10, pid = 4866]
Jul  2 23:57:10 cctv zmdc[4866]: INF ['zmfilter.pl' started at 10/07/02 23:57:10]
Jul  2 23:57:10 cctv zmdc[4778]: ERR ['zmfilter.pl ' exited abnormally, exit status 9]
Jul  2 23:57:11 cctv zmdc[4778]: INF [Starting pending process, zmc -d /dev/video0]
Jul  2 23:57:11 cctv zmdc[4778]: INF ['zmc -d /dev/video0' starting at 10/07/02 23:57:11, pid = 4868]
Jul  2 23:57:11 cctv zmdc[4868]: INF ['zmc -d /dev/video0' started at 10/07/02 23:57:11]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: INF [Debug Level = 0, Debug Log = <none>]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: INF [Starting Capture]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: WAR [Hue control is not suppported]
Jul  2 23:57:11 cctv kernel: gspca: found int in endpoint: 0x83, buffer_len=1, interval=100
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: INF [Got signal 11 (Segmentation fault), crashing]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Signal address is 0xb7724000, from 0x6704af]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Backtrace: /lib/libc.so.6(+0x12a4af) [0x6704af]]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Backtrace: /lib/libc.so.6(+0x12a4af) [0x6704af]]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Backtrace: /usr/bin/zmc() [0x8064023]]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Backtrace: /usr/bin/zmc() [0x806ccc5]]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Backtrace: /usr/bin/zmc() [0x804c094]]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Backtrace: /lib/libc.so.6(__libc_start_main+0xe6) [0x55ccc6]]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: ERR [Backtrace: /usr/bin/zmc() [0x804b911]]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: INF [Backtrace complete, please execute the following command for more information]
Jul  2 23:57:11 cctv zmc_dvideo0[4868]: INF [addr2line -e /usr/bin/zmc() 0x6704af 0x6704af 0x8064023 0x806ccc5 0x804c094 0x55ccc6 0x804b911]
Jul  2 23:57:11 cctv kernel: gspca: found int in endpoint: 0x83, buffer_len=1, interval=100
Jul  2 23:57:11 cctv zmdc[4778]: ERR ['zmc -d /dev/video0' exited abnormally, exit status 11]


Detailed Description:

SELinux denied access requested by nph-zms. It is not expected that this access
is required by nph-zms and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:httpd_t:s0
Target Context                unconfined_u:system_r:initrc_t:s0
Target Objects                None [ shm ]
Source                        nph-zms
Source Path                   /usr/libexec/zoneminder/cgi-bin/nph-zms
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           zoneminder-1.24.2-4.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.33.5-124.fc13.i686 #1 SMP
                              Fri Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   2
First Seen                    Fri 02 Jul 2010 11:56:59 PM PDT
Last Seen                     Fri 02 Jul 2010 11:56:59 PM PDT
Local ID                      b4983058-51fb-4c46-8440-1048ebbdc677
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1278140219.243:27652): avc:  denied  { read write } for  pid=4857 comm="nph-zms" key=2053963777  scontext=unconfined_u:system_r:httpd_t:s0 tcontext=unconfined_u:system_r:initrc_t:s0 tclass=shm

node=(removed) type=SYSCALL msg=audit(1278140219.243:27652): arch=40000003 syscall=117 success=no exit=-13 a0=15 a1=200009 a2=0 a3=bf8f95c8 items=0 ppid=2918 pid=4857 auid=500 uid=48 gid=488 euid=48 suid=48 fsuid=48 egid=488 sgid=488 fsgid=488 tty=(none) ses=1 comm="nph-zms" exe="/usr/libexec/zoneminder/cgi-bin/nph-zms" subj=unconfined_u:system_r:httpd_t:s0 key=(null)



Hash String generated from  catchall,nph-zms,httpd_t,initrc_t,shm,read,write
audit2allow suggests:

#============= httpd_t ==============
allow httpd_t initrc_t:shm { read write };
Comment 1 Miroslav Grepl 2010-07-04 17:42:35 EDT

*** This bug has been marked as a duplicate of bug 611016 ***

Note You need to log in before you can comment on or make changes to this bug.