Bug 61108 - Compaq SP700 hang on reboot under RH7.2
Compaq SP700 hang on reboot under RH7.2
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
http://www.asf.com/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 13:48 EST by Alex Aguila
Modified: 2015-01-04 17:01 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 10:07:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Aguila 2002-03-13 13:48:13 EST
Description of Problem:
I have several Compaq Professional Workstation SP700 machines running RedHat 
7.2.  When I do a "reboot", a "shutdown -r 0", or just press [ctl]+[alt]+[del]
to reboot the machine, the system properly executes it's shutdown scripts and 
attempts to reboot.  However, instead of rebooting, the machine beeps and then 
hangs.  This occurs whether I have advanced power management turned on or off 
in Bios.

The machine is then un-responsive - the only way to reboot the machine at that 
point is to manually cycle the power.  This is unacceptable, as these machines 
are remote administered, and the occasional reboot is required.


Version-Release number of selected component (if applicable):
kernel-smp-2.4.7-10, kernel-2.4.7-10

How Reproducible:
Every time.

Steps to Reproduce:
1. Install RH 7.2 on a Compaq Professional Workstation SP700
2. After the SP700 comes up, attempt to reboot via reboot, shutdown -r 0, or 
ctl+alt+del.
3. Machine will process all shutdown scripts correctly and attempt to reboot.

Actual Results:
Upon attempting to reboot, the SP700 will beep, and hang/crash.

Expected Results:
SP700 should have rebooted, and the boot it's installed OS.

Additional Information:
- The specifications for the Compaq Professional Workstation SP700 can be found 
at http://www.compaq.com/products/workstations/sp700/index.html

- Additional system info: 128MB Ram, ATI Xpert 98 AGP or Matrox Millenium II 
PCI video cards, Dual Xeon II 450mhz processors, 9.1 Seagate SCSI HDD.

- This problem manifests itself on both SMP and single processor versions of 
the kernel.

- This problem manifested itself in RH 7.2.  It was not present in RH 6.2, the 
previous version of Red Hat on these machines.

- If I do a ctl+alt+del while the machine is booting (read - while the pretty 
penguins are in the upper left corner of the screen) BEFORE I get to the init 
scripts (v2.78 on a stock machine), the machine boots fine.  After the the 
machine hits the init scripts, it will hang upon reboot.

- The SP700 machine reboots correctly under other OS's, such as the various 
Windows versions, as well as under Free/Open/NetBSD.  Again, it did work ok 
under RH6.2, but not RH7.2.

- Finally, ASF has a support contract with Red Hat, and would be happy to 
supply any assistance to getting this matter resolved as quicly as possible, as 
we cannot deploy these machines until they can be rebooted remotely (they are 
remote admined).  If Red Hat needs access to one of these machines, please 
contact me at aaguila@asf.com and we can make arrangements if necessary.
Comment 1 Alex Aguila 2002-03-13 13:54:51 EST
eratta: I had a couple of typo's...   ^_^;

-Expected Results:
SP700 should have rebooted, and *THEN BOOTED TO* it's installed OS.

- If I do a ctl+alt+del while the machine is booting (read - while the pretty 
penguins are in the upper left corner of the screen) BEFORE I get to the init 
scripts (v2.78 on a stock machine), the machine *REBOOTS* fine.  After the the 
machine hits the init scripts, it will hang upon reboot.
Comment 2 Arjan van de Ven 2002-03-13 14:01:51 EST
Ok there's a couple of things that can be tried to control how the kernel
reboots the machine, each are in the form of adding a "reboot=X" flag to the
kernel commandline. You need to add that to the vmlinuz line in /boot/grub/grub.conf
or, in case of lilo, as an append line (for trying with lilo you can just type
"linux reboot=X" on the lilo prompt).

reboot=w
 --- "warm" reboot (no memory testing etc)

reboot=c
 --- cold" reboot (with memory testing etc)

reboot=b
 --- use the bios for rebooting (<--- try this one first as most likely        
                 candidate)

reboot=s
 --- on smp systems, use the cpu #0 for rebooting
Comment 3 Alex Aguila 2002-03-15 18:42:59 EST
We made a little bit of progress.  Unfortunately, it looks like one fix causes 
another problem...  ^_^;;

I tried reboot=[w,c,b,s,h] at the lilo prompt, and various combinatins therein 
(e.g., reboot=b,w, reboot=w, etc.).  The only one that actually made any sort 
of difference was reboot=w.  When I used that particular paramater, the machine 
would indeed reboot after a "reboot", "shutdown -r 0" or ctl+alt+del, but after 
it rebooted it would not find it's hard disk...

Specifically, the machine resets, detects it's processors, and then attempts to 
detect it's hard disk, which is connected to the internal scsi bus (it's an 
onboard sym53c875 chipset).  At that point, the screen reads "Scanning for SCSI 
Devices..." for about 3 minutes.  But instead of detecting the disk on the scsi 
bus, the detection fails with the following: "SCSI Controller, System Board, 
Port 1: ID 0 - FAILED, ID 1 - FAILED, .... ID 15 - FAILED".  After that, we get 
the classic "Non-system disk or disk error, replace and strike any key when 
ready" message that gets reported on PC's when they can't find a good disk to 
boot from.  Cycling the power fixes the problem.

Sooo....  In a nutshell, seems to me that the scsi bus is getting hung after a 
warm boot via reboot=w paramater.  It's farther than we were before, but it 
still does not reboot the machine right...

Ideas?  Help!!
Comment 4 David A. Loegering 2003-10-29 10:59:48 EST
I got the Compaq SP700 to work with RedHat 8.0 and assume it would work the 
same for RedHat 7.2

It is a several step process.  

Not sure why I have to set the bios settings this way but the system will hang 
intermittently if I set them differently than this

Power /Energy Saver -- disabled

Advanced / PCI Devices / compaq scsi -- disabled (I have a Smart-2/p array 
control installed, compaq scsi is listed twice, I disabled the first of the two)

Advanced / Power-On Self Test / Post messages -- enable post error messages

Then during the install I pass the following parameters to the kernel

linux reboot=bios,warm

or a person could just edit the /etc/lilo.conf append line.  My edited line 
reads

append="linux reboot=bios,warm root=LABEL=/"

After that in the /sbin directory I created a file named halt.local and made it 
executeable.  In this file I rmmod every module that loads in 
the /etc/modules.conf file.  If I leave even just one of the modules loaded it 
will hang and not find the drives on reboot.  My files contents are 

/sbin/rmmod parport_pc
/sbin/rmmod cpqarray
/sbin/rmmod tlan
/sbin/rmmod eepro100
/sbin/rmmod sym53c8xx
/sbin/rmmod usb-ohci
/sbin/rmmod ohci1394

After having done all that I still have to have the system shutdown 
gracefully.  By this I mean I can only use the "shutdown -r now" command or the 
ctl-alt-del to reboot.  If I have the system shutdown using h, f, or n the 
system will not find the drives once it boot up again.  

I tried cutting out parts of this, not setting the bios settings, skipping 
the "reboot=bios,warm" line, not using the rmmod on the modules but I seem to 
have to have all the parts to make it work right.

Note You need to log in before you can comment on or make changes to this bug.