Bug 61112 - Corrupt file on redhat update ftp server/mirrors.
Corrupt file on redhat update ftp server/mirrors.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: libgcj (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
ftp://updates.redhat.com/7.2/en/os/i3...
: Security
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-13 15:02 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 15:26:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-13 15:02:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204

Description of problem:
Whenever I try installing this rpm (part of the zlib update) I get this message
which indicates that the file is corrupt:

warning: Expected size:      3019632 = lead(96)+sigs(293)+pad(3)+data(3019240)
warning:   Actual size:      2908348


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download the file from
ftp://updates.redhat.com/7.2/en/os/i386/libgcj3-devel-3.0.4-1.i386.rpm
2.rpm -Uvh libgcj3-devel-3.0.4-1.i386.rpm
3.See error message....
	

Actual Results:  The file appears to be corrupt and may cause problems with gcc3
if installed.

Expected Results:  The filesize is wrong and the package is corrupt; this
package may have been uploaded to the redhat ftp server in ascii format instead
of binary format.  Can you please fix it so I can update my gcc3?

Additional info:

This file is part of the packages that were updated to fix the zlib security
problem.
Comment 1 Jakub Jelinek 2002-03-13 15:11:48 EST
Cannot reproduce this:
ls -l 7.2/en/os/i386/libgcj3-devel-3.0.4-1.i386.rpm
-rw-rw-r--    1 mirrors  mirrors   3019632 Mar 11 04:37 7.2/en/os/i386/libgcj3-devel-3.0.4-1.i386.rpm
rpm -K 7.2/en/os/i386/libgcj3-devel-3.0.4-1.i386.rpm
7.2/en/os/i386/libgcj3-devel-3.0.4-1.i386.rpm: md5 gpg OK
(this is on an redhat.com mirror).
Comment 2 Need Real Name 2002-03-13 15:15:15 EST
What mirror is this? The file on the updates.redhat.com server is still wrong.
Comment 3 Need Real Name 2002-03-13 15:26:49 EST
I've tried about a dozen different mirrors now and so far all of them have the
corrupt file.
Comment 4 Jakub Jelinek 2002-03-13 15:35:55 EST
I'm afraid it must be your local issue.
The mirror in question was sunsite.mff.cuni.cz, but I've just tried
wget ftp://ftp.redhat.com/pub/redhat/linux/updates/7.2/en/os/i386/libgcj3-devel-3.0.4-1.i386.rpm
rpm -K libgcj3-devel-3.0.4-1.i386.rpm
libgcj3-devel-3.0.4-1.i386.rpm: md5 gpg OK

Note You need to log in before you can comment on or make changes to this bug.