Bug 611149 - F13 complains that Sony GDM-400PS monitor's EDID is invalid
F13 complains that Sony GDM-400PS monitor's EDID is invalid
Status: CLOSED DUPLICATE of bug 582712
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
: 649949 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-03 19:25 EDT by James Ralston
Modified: 2018-04-11 14:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-26 13:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/dmesg from F13 system with Sony GDM-400PS attached (63.50 KB, text/plain)
2010-07-03 19:29 EDT, James Ralston
no flags Details
/var/log/Xorg.0.log from F13 system with Sony GDM-400PS attached (69.28 KB, text/plain)
2010-07-03 19:30 EDT, James Ralston
no flags Details
/var/log/Xorg.9.log file from F12 system with GDM-400PS attached (33.03 KB, text/plain)
2010-07-03 19:34 EDT, James Ralston
no flags Details
/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf from F13 system with Sony GDM-400PS attached (321 bytes, text/plain)
2010-07-03 19:38 EDT, James Ralston
no flags Details
/boot/grub/grub.conf file from F13 system with Sony GDM-400PS attached (816 bytes, text/plain)
2010-07-03 19:42 EDT, James Ralston
no flags Details

  None (edit)
Description James Ralston 2010-07-03 19:25:49 EDT
I have a Sony GDM-400PS monitor that is about 15 years old. I have been using this monitor with Red Hat Linux 7.2 through Fedora 12, and have never had any issues with it.

I have been using KMS since it became the default (Fedora 12, I think). Again, no issues.

However, Fedora 13 does not care for this monitor.  Specifically, when the radeon driver loads at system boot, this error message appears in dmesg:

[drm:drm_edid_block_valid] *ERROR* EDID checksum is invalid, remainder is 48
[drm:drm_edid_block_valid] *ERROR* Raw EDID:
<3>50 df ff ff ff ff ff 00 4d d9 90 00 a6 2c 6b 00  P.......M....,k.
<3>1e 08 01 01 0e 25 1b 96 e8 0d c9 a0 57 47 98 27  .....%......WG.'
<3>12 48 4c ff ff 80 31 59 45 59 61 59 71 59 81 8f  .HL...1YEYaYqY..
<3>81 99 a9 40 a9 4f d6 09 80 a0 20 e0 2d 10 10 60  ...@.O.... .-..`
<3>a2 00 60 08 11 00 00 18 00 00 00 ff 00 37 30 32  ..`..........702
<3>33 37 38 32 0a 20 20 20 20 20 00 00 00 fc 00 47  3782.     .....G
<3>44 4d 2d 31 39 50 53 0a 20 20 20 20 00 00 00 fd  DM-19PS.    ....
<3>00 30 a0 1e 5f ff 00 0a 20 20 20 20 20 20 00 d1  .0.._...      ..

Because of this, I am limited to only very basic video modes (e.g., 1024x768 @ 60Hz).

I suspect one of two things is true:

1. The Sony GDM-400PS EDID is actually valid, but a bug was introduced in the radeon driver in F13 that causes it to mis-parse this particular EDID.

2. The Sony GDM-400PS EDID is invalid (and always has been), but the radeon driver only recently started complaining about it.

If #1 is the case, then, well, please fix.  ;-)

If #2 is the case... while I appreciate that the radeon driver now detects bogus EDIDs, this essentially cripples the functionality of my monitor. Please add a quirk/workaround for this particular monitor.

(I am a Fedora developer, and am well-versed in compiling kernels from SRPM. So, if you believe you have a fix for this, I'll be happy to test it.)
Comment 1 James Ralston 2010-07-03 19:29:29 EDT
Created attachment 429312 [details]
/var/log/dmesg from F13 system with Sony GDM-400PS attached
Comment 2 James Ralston 2010-07-03 19:30:47 EDT
Created attachment 429313 [details]
/var/log/Xorg.0.log from F13 system with Sony GDM-400PS attached
Comment 3 James Ralston 2010-07-03 19:34:35 EDT
Created attachment 429315 [details]
/var/log/Xorg.9.log file from F12 system with GDM-400PS attached

Because I save /var/log across reinstalls of Fedora, I had a leftover /var/log/Xorg.9.log file from when I had F12 install on this box.

As you can see from this log, the F12 radeon driver had no issues with the EDID that the Sony GDM-400PS sends.
Comment 4 James Ralston 2010-07-03 19:38:08 EDT
Created attachment 429316 [details]
/etc/X11/xorg.conf.d/00-system-setup-keyboard.conf from F13 system with Sony GDM-400PS attached

This is the only file that exists in the /etc/X11/xorg.conf.d/ directory on the system in question
Comment 5 James Ralston 2010-07-03 19:42:47 EDT
Created attachment 429317 [details]
/boot/grub/grub.conf file from F13 system with Sony GDM-400PS attached

I remove "quiet rhgb" from the kernel arguments (because I'm old school), but I do use KMS.
Comment 6 James Ralston 2010-11-24 17:59:26 EST
I've since upgraded all my boxes to Fedora 14, and moved the Sony GDM-400PS monitor to my firewall box. The errors persist, and follow the monitor.

Also, short of disconnecting the monitor entirely, how do I make it stop spewing warning messages about the invalid EDID every 10 seconds? I *know* it thinks the EDID is invalid, but I don't need 10MiB worth of daily log data to that effect.
Comment 7 Matěj Cepl 2010-11-26 13:42:25 EST
*** Bug 649949 has been marked as a duplicate of this bug. ***
Comment 8 Matěj Cepl 2010-11-26 13:44:17 EST

*** This bug has been marked as a duplicate of bug 582712 ***

Note You need to log in before you can comment on or make changes to this bug.