Bug 611285 (pyvcs) - Review Request: pyvcs - A lightweight abstraction layer over multiple VCSs
Summary: Review Request: pyvcs - A lightweight abstraction layer over multiple VCSs
Keywords:
Status: CLOSED ERRATA
Alias: pyvcs
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mario Blättermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: python-dulwich
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-04 17:38 UTC by Fabian Affolter
Modified: 2011-04-15 21:25 UTC (History)
4 users (show)

Fixed In Version: pyvcs-0.2.0-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-15 20:49:24 UTC
mario.blaettermann: fedora-review+
tibbs: fedora-cvs+


Attachments (Terms of Use)

Description Fabian Affolter 2010-07-04 17:38:20 UTC
Spec URL: http://fab.fedorapeople.org/packages/SRPMS/pyvcs.spec
SRPM URL: http://fab.fedorapeople.org/packages/SRPMS/pyvcs-0.2.0-1.fc13.src.rpm

Project URL: http://pypi.python.org/pypi/pyvcs

Description:
pyvcs is a minimal VCS abstraction layer for Python.  It's goals are
to provide as much functionality as is necessary, and no further.  It
doesn't try to abstract every layer or feature of a VCS, just what's
necessary to build a code browsing UI.

Koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2294135

rpmlint output:
[fab@laptop011 SRPMS]$ rpmlint pyvcs-0.2.0-1.fc13.src.rpm 
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

[fab@laptop011 noarch]$ rpmlint pyvcs-0.2.0-1.fc13.noarch.rpm 
1 packages and 0 specfiles checked; 0 errors, 0 warnings.

Comment 1 Mario Blättermann 2011-03-27 12:50:07 UTC
There is a license difference in your files: The spec file says BSD, the src.rpm says GPLv2+. According to the project page, the actual license is BSD, please keep this in mind for your further work on this package.

$ rpmlint -v pyvcs*
pyvcs.spec: I: checking-url http://pypi.python.org/packages/source/p/pyvcs/pyvcs-0.2.0.tar.gz (timeout 10 seconds)
0 packages and 1 specfiles checked; 0 errors, 0 warnings.

$ rpmlint -v pyvcs*
pyvcs.src: I: checking
pyvcs.src: I: checking-url http://pypi.python.org/pypi/pyvcs (timeout 10 seconds)
pyvcs.src: I: checking-url http://pypi.python.org/packages/source/p/pyvcs/pyvcs-0.2.0.tar.gz (timeout 10 seconds)
1 packages and 0 specfiles checked; 0 errors, 0 warnings.


---------------------------------
key:

[+] OK
[.] OK, not applicable
[X] needs work
---------------------------------

[+] MUST: The package must be named according to the Package Naming Guidelines.
[+] MUST: The spec file name must match the base package %{name}.
[+] MUST: The package must meet the Packaging Guidelines.
[+] MUST: The package must be licensed with a Fedora approved license.
    - BSD according to the project page

[+] MUST: The License field in the package spec file must match the actual
license.
    - Source rpm already contains the actual license

[+] MUST: The file containing the text of the license(s) for the package must
be included in %doc.
[+] MUST: The spec file must be written in American English.
[+] MUST: The spec file for the package MUST be legible.
[+] MUST: The sources used to build the package must match the upstream source.
    $ md5sum pyvcs*
    284caf99b824ec4848d642608736edfe  pyvcs-0.2.0.tar.gz
    284caf99b824ec4848d642608736edfe  pyvcs-0.2.0.tar.gz.packaged

[+] MUST: The package MUST successfully compile and build into binary rpms on
at least one primary architecture.
    - Koji scratch build was succesful.

[.] MUST: If the package does not successfully compile, build or work on an
architecture, ...
[+] MUST: All build dependencies must be listed in BuildRequires.
[.] MUST: When compiling C, C++, or Fortran files, %{optflags} must be applied.
[.] MUST: The spec file MUST handle locales properly.
[.] MUST: Packages storing shared library files (not just symlinks) must call
ldconfig in %post and %postun.
[+] MUST: Packages must NOT bundle copies of system libraries.
[.] MUST: If the package is designed to be relocatable, ...
[+] MUST: A package must own all directories that it creates. 
[+] MUST: A Fedora package must not list a file more than once in %files.
[+] MUST: Permissions on files must be set properly.
[+] MUST: Each package must consistently use macros.
[+] MUST: The package must contain code, or permissable content.
[.] MUST: Large documentation files must go in a -doc subpackage.
[+] MUST: Files in %doc must not affect the runtime of the application.
[.] MUST: Header files must be in a -devel package.
[.] MUST: Static libraries must be in a -static package.
[.] MUST: If a package contains library files with a suffix (e.g.
libfoo.so.1.1), ...
[.] MUST: devel packages must require the base package using a fully versioned
dependency.
[.] MUST: Packages must NOT contain any .la libtool archives.
[.] MUST: Packages containing GUI applications must include a %{name}.desktop
file
[+] MUST: Packages must not own files or directories already owned by other
packages.
[+] MUST: All filenames in rpm packages must be valid UTF-8.

[.] SHOULD: If the source package does not include license text(s) as a
separate file from upstream,...
[+] SHOULD: Timestamps of files should be preserved.
[+] SHOULD: The reviewer should test that the package builds in mock.
    - Koji scratch build available, see above

[+] SHOULD: The package should compile and build into binary rpms on all
supported architectures.
[+] SHOULD: The reviewer should test that the package functions as described.
[.] SHOULD: If scriptlets are used, those scriptlets must be sane.
[.] SHOULD: Usually, subpackages other than devel should require the base
package using a fully versioned dependency.
[.] SHOULD: pkgconfig(.pc) files should be placed in a -devel pkg.
[.] SHOULD: If the package has file dependencies outside of /etc, /bin, /sbin,
/usr/bin, or /usr/sbin consider requiring the package which provides the file
instead of the file itself.
[+] SHOULD: Your package should contain man pages for binaries/scripts.
    - Currently no manpage available.


----------------
Package APPROVED
----------------

Comment 2 Fabian Affolter 2011-03-27 14:04:31 UTC
Thanks for the review, Mario.

(In reply to comment #1)
> There is a license difference in your files: The spec file says BSD, the
> src.rpm says GPLv2+. According to the project page, the actual license is BSD,
> please keep this in mind for your further work on this package.

Yes, the license is BSD. I will fix that.

Comment 3 Fabian Affolter 2011-03-27 14:05:48 UTC
New Package SCM Request
=======================
Package Name: pyvcs
Short Description: A lightweight abstraction layer over multiple VCSs
Owners: fab
Branches: f14 f15
InitialCC:

Comment 4 Jason Tibbitts 2011-03-27 19:41:13 UTC
Git done (by process-git-requests).

Comment 5 Fedora Update System 2011-03-28 18:55:50 UTC
pyvcs-0.2.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/pyvcs-0.2.0-1.fc14

Comment 6 Fedora Update System 2011-03-28 18:55:58 UTC
pyvcs-0.2.0-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/pyvcs-0.2.0-1.fc15

Comment 7 Fedora Update System 2011-03-29 03:32:55 UTC
pyvcs-0.2.0-1.fc15 has been pushed to the Fedora 15 testing repository.

Comment 8 Fedora Update System 2011-04-15 20:49:18 UTC
pyvcs-0.2.0-1.fc14 has been pushed to the Fedora 14 stable repository.

Comment 9 Fedora Update System 2011-04-15 21:25:46 UTC
pyvcs-0.2.0-1.fc15 has been pushed to the Fedora 15 stable repository.


Note You need to log in before you can comment on or make changes to this bug.