Bug 611310 - Flash broken on latest firefox and nspluginwrapper for x86_64
Summary: Flash broken on latest firefox and nspluginwrapper for x86_64
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nspluginwrapper   
(Show other bugs)
Version: 13
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-04 20:00 UTC by A. Folger
Modified: 2010-11-03 10:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-03 10:34:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description A. Folger 2010-07-04 20:00:56 UTC
Description of problem:
Flash no longer works for me. I have described the issue in another bug report, https://bugzilla.redhat.com/show_bug.cgi?id=523273 , but since this is an independent issue, I am refiling.

Version-Release number of selected component (if applicable):
[user@localhost ~]$ rpm -q firefox nspluginwrapper flash-plugin
firefox-3.6.4-1.fc13.x86_64
nspluginwrapper-1.3.0-13.fc13.x86_64
nspluginwrapper-1.3.0-13.fc13.i686
flash-plugin-10.1.53.64-release.i386


How reproducible:
start firefox, go to a page with flash (e.g. Youtube), and see how there is ... no flash.

Expected results:
Flash plays.

Additional info:
As explained in the https://bugzilla.redhat.com/show_bug.cgi?id=523273 , until last week, it all worked. But somehow, after the update of nspluginwrapper, it no longer works. Oh, and this is definitely a x(&_64 issue, as I tested it on another box with i686, and there it works like a charm.

When starting firefox from the command line, I get about a dozen times the following error message:

LoadPlugin: failed to initialize shared library /usr/lib64/mozilla/plugins/npwrapper.libflashplayer.so [/usr/lib64/mozilla/plugins/npwrapper.libflashplayer.so: wrong ELF class: ELFCLASS32]

Comment 1 Jonathan Kamens 2010-07-07 14:58:34 UTC
Looks like you've got the 32-bit Flash plugin from Adobe deployed on your 64-bit system. The error message says that you've got a 32-bit DLL in /usr/lib64, which is just wrong. How did it get there? How did you deploy it?

You should follow the instructions in https://fedoraproject.org/wiki/Multimedia/Flash for wrapping the 32-bit plugin on 64-bit systems. I don't think anybody here is going to be able to support any methods besides that for getting Flash running on an x86_64 system.

Comment 2 A. Folger 2010-07-07 15:54:23 UTC
Ah. Makes sense. I had noticed that despite having upgraded Flash a while ago, FF was still using an older version, which led me to delete .mozilla/plugins, which in turn led me to the bug (which was fixed a few days ago, referred to above) with nspluginwrapper, which until I figured out what was going on, led me to try to tweak flash, and at that point, I may have inadvertently done this stupidity. Eventually, nspluginwrapper was fixed, but the damage had been done.

Thanks!

Comment 3 A. Folger 2010-08-18 09:45:47 UTC
I see this bug is still listed as NEW. Since it was solved six weeks ago, feel free to change status to CLOSED/SOLVED.


Note You need to log in before you can comment on or make changes to this bug.