Bug 61139 - updates dependency problems with numerous RPMs on updates.redhat.com
updates dependency problems with numerous RPMs on updates.redhat.com
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
: Security
Depends On:
  Show dependency treegraph
Reported: 2002-03-14 01:30 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-14 01:34:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-03-14 01:30:50 EST
From Bugzilla Helper:
User-Agent: Some web browser

Description of problem:
After downloading all updates for RH 7.1, the following dependency problems arise:

# rpm -Fvh *.rpm
error: failed dependencies:
        kernel-drm = 4.1.0 is needed by XFree86-4.1.0-15
This RPM not in updates.  Clearly not distributed with RH 7.1, which came with
XF86 4.0.3
        xinitrc >= 3.13 is needed by XFree86-xdm-4.1.0-15
This also not available in updates.  7.1 ships with xinitrc-3.6-1
        filesystem >= 2.1.0 is needed by mkinitrd-3.2.6-1
This also not available in updates.  7.1 ships with filesystem-2.0.7-1
        webserver is needed by mod_ssl-2.8.5-3
Beats the hell out of me:
$ rpm -q apache
[ddm@luna tmp]
$ rpm -q --whatprovides webserver

        libmm.so.11   is needed by php-4.0.6-9.7.1
No idea what this is...
$ rpm -q php
$ rpm -q --whatprovides libmm.so
no package provides libmm.so

        libpspell.so.2   is needed by php-4.0.6-9.7.1
$ rpm -q --provides pspell
pspell = 2:0.12.2-ximian.3

Ok, so Ximain sucks...
        up2datepoptmodule.so is needed by up2date-2.7.11-7.x.1
Eh? This seems to be in a package that's missing...


Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install RH 7.1
2. Download all updates
3. rpm -Fvh *.rpm

Watch dependencies fail

Additional info:

I picked "security" as the severity because several of the updates are for
security fixes, but they won't install because of broken dependencies.

Additionally, some packages in the updates directory have multiple versions.
This makes rpm -Fvh *.rpm break, and you have to manually remove the duplicate
pacakges.  That sucks.

Have a nice day.
Comment 1 Need Real Name 2002-03-14 01:34:37 EST
Oops, scratch off the webserver dependency problem.  Ran the commands on the
wrong host.  The rest are still just as valid though.
Comment 2 Mike A. Harris 2002-03-14 08:37:59 EST
The XFree86 update was well tested on a variety of machines and works
perfectly if it is applied correctly.  The errors you are seeing are
because you have not first installed the dependant packages that the
new XFree86 erratum requires.  First off you need to install the
latest erratum kernel, which provides kernel-drm virtual package.
You will need to also upgrade the rest of the packages that were
released as part of the XFree86 advisory as well, and you can find
that advisory on our website.  The easiest way of applying the update
is to use up2date, which simplifies things.

If you have difficulty applying the package updates in the right order,
please consult one of our end-user mailing list support forums.

Closing bug as NOTABUG, as this is a technical support issue, not a
bug, and bugzilla is not a technical support forum.

Note You need to log in before you can comment on or make changes to this bug.