Bug 61141 - vim 100% CPU usage after closing xterm with 'vim file' opend.
vim 100% CPU usage after closing xterm with 'vim file' opend.
Status: CLOSED DUPLICATE of bug 83700
Product: Red Hat Linux
Classification: Retired
Component: vim (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
: 76822 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-14 03:49 EST by Need Real Name
Modified: 2007-04-18 12:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bugreport created with 'vim -s /usr/share/vim/vim60/bugreport.vim' (55.17 KB, text/plain)
2002-03-19 07:13 EST, Need Real Name
no flags Details
VIM Wrapper: workaround for this bug (738 bytes, text/plain)
2002-05-07 09:11 EDT, preed
no flags Details

  None (edit)
Description Need Real Name 2002-03-14 03:49:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020212

Description of problem:
Vim crashes with 100% CPU usage after closing xterm without prior extitng from
editing a file. /bin/vi has not the bug.

/bin/vi      - vim-minimal-6.0-7.13
/usr/bin/vim - vim-enhanced-6.0-7.13

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. xterm
2. vim 123
3. close xterm window
	

Additional info:
Comment 1 Bernhard Rosenkraenzer 2002-03-19 06:10:28 EST
Can't reproduce this.
Comment 2 Need Real Name 2002-03-19 07:13:46 EST
Created attachment 48967 [details]
Bugreport created with 'vim -s /usr/share/vim/vim60/bugreport.vim'
Comment 3 Need Real Name 2002-03-19 07:18:45 EST
You need to have vim-enhanced-6.0-7.13 installed and the try to edit a file
with vim in a window (xterm). Do not exit from vim but close the window with 
the close button on the right top side of the window. Open another Window 
and look at the CPU usage of the not terminated vim program it is nearly 100%, 
the machine in locked up. 
I discovered this after I have installed vim-enhanced and some users terminates
vim as described.

vim bugreport.vim created on a Red Hat Linux release 7.2 (Enigma) PIII Machine.
Comment 4 preed 2002-05-02 14:07:57 EDT
You can also reproduce this bug by simply sending the vim process a HUP; I had
this problem with 100% CPU usage on vim processes that had been attempted to be
killed by an idled process that was logging users out for excessive idle time.
Comment 5 preed 2002-05-07 09:08:54 EDT
Here's some more info: it looks like the SIGSEGV handler is ignoring the signal
somewhere... I started up vim (/usr/bin/vim, NOT /bin/vi, which is why you
probably didn't observe the bug earlier), attached an strace monitor to it, sent
it a HUP signal via kill on the command line, and got the following:

write(1, "\33[?25l\33[25;63H1,0-1\33[1;1H\33[?25h", 31) = 31
select(1, [0], NULL, [0], {4, 0})       = 0 (Timeout)
select(1, [0], NULL, [0], NULL)         = ? ERESTARTNOHAND (To be restarted)
--- SIGHUP (Hangup) ---
--- SIGSEGV (Segmentation fault) ---
--- SIGSEGV (Segmentation fault) ---
--- SIGSEGV (Segmentation fault) ---
--- SIGSEGV (Segmentation fault) ---
...

Hope this helps.
Comment 6 preed 2002-05-07 09:11:32 EDT
Created attachment 56504 [details]
VIM Wrapper: workaround for this bug
Comment 7 Need Real Name 2002-07-17 05:21:19 EDT
This happens if vim loses it's tty for whatever reason, I can reproduce this by
killing an ssh session, leaving vim sucking CPU.  I have the following rpms
installed:
vim-enhanced-6.1-2
vim-minimal-6.1-2

While vim is sucking CPU, LIDS spurts these messages:
SECURITY WARNING: SIG 11 sent to [vim:1306], UID(0), EUID(0), parent [init:1],
UID(0), EUID(0)

and an strace shows:
[john@dwight john]$ strace -p 3130
select(1, [0], NULL, [0], NULL)         = 1 (in [0])
(note:tty dropped here)
--- SIGHUP (Hangup) ---
--- SIGSEGV (Segmentation fault) ---
--- SIGSEGV (Segmentation fault) ---
and on, and on, and ariston....
Comment 8 Carwyn Edwards 2002-11-19 06:45:17 EST
Is this not a related bug to bug number 76822?

Also note the following references:

http://vimdoc.sf.net/cgi-bin/vimfaq2html3.pl#29.9
http://groups.yahoo.com/group/vim/message/32547

Note that this definately does not happen on RH8.0
Comment 9 Tomas Kasparek 2002-11-19 07:21:07 EST
*** Bug 76822 has been marked as a duplicate of this bug. ***
Comment 10 Karsten Hopp 2003-06-20 08:00:31 EDT

*** This bug has been marked as a duplicate of 83700 ***
Comment 11 Red Hat Bugzilla 2006-02-21 13:48:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.