Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 611436 - Make bundle creation error messages more friendly
Make bundle creation error messages more friendly
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Provisioning (Show other bugs)
3.0.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Sunil Kondkar
:
: 616262 (view as bug list)
Depends On:
Blocks: rhq_triage jon24-provisioning
  Show dependency treegraph
 
Reported: 2010-07-05 05:19 EDT by Rajan Timaniya
Modified: 2010-12-14 09:40 EST (History)
4 users (show)

See Also:
Fixed In Version: 3.0.0.GA 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-14 09:40:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (51.30 KB, image/png)
2010-07-05 05:19 EDT, Rajan Timaniya
no flags Details

  None (edit)
Description Rajan Timaniya 2010-07-05 05:19:47 EDT
Created attachment 429494 [details]
screenshot

Description of problem:
Bundle creation via URL_invalid URL –  didn't display error message and failure reason.

Version-Release number of selected component (if applicable):
JON 2.4 GA_QA (tag-jon-release build# 49)
build number: 10775:e086474

How reproducible:
Always

Steps to Reproduce:
1. Go to Administration->Content->Bundles
2. Click on button 'New'.
3. Select the radio button 'URL'.
4. Enter an invalid URL type in text box
   (Ex: Enter plain text or special characters in text box)
5. Click on Next button.
  
Actual results:
Bundle creation via URL_invalid URL –  didn't display error message and failure reason.

Expected results:
UI should display proper error message and failure reason in the wizard box.

Additional info:
Please refer attached screenshot.
Comment 1 Rajan Timaniya 2010-07-05 05:24:16 EDT
Same issue find when user select the radio button 'URL' and without provide
any url click on 'Next' button.

Expected results:
UI should display proper error message and failure reason in the wizard box.
Comment 2 Sunil Kondkar 2010-07-05 07:31:50 EDT
Updating the bug for the same observation: When user uploads an empty or invalid recipe, or when user selects recipe option and proceeds without entering recipe details. The error message displayed is in the 'Messages' dropdown. 

Expected result: The error message and failure reason should be displayed in the wizard box.
Comment 3 Jay Shaughnessy 2010-07-07 15:52:20 EDT
fix commit: 91c9d1fb7849b9966f60a2cdeb8bca1903e3389c

There is a new messaging and is displayed within the wizard.
Comment 4 Sunil Kondkar 2010-07-09 05:04:00 EDT
Tested on latest jon 2.4.0.GA_QA build#53

Below are the observations:

1) When user enters invalid URL type(asdasd) in text box and click 'Next'- The bundle creation wizard displays: 

java.net.MalformedURLException:no protocol: asdasd

2) When user select the radio button 'URL' and clicks on 'Next' button without providing any url-The bundle creation wizard displays: 
 
java.net.MalformedURLException:null

3) When user uploads an empty or invalid recipe-The bundle creation wizard displays: 

javax.ejb.EJBException:java.lang.IllegalArgumentException: Invalid recipe not recognized by any deployed server bundle plugin. -> java.lang.IllegalArgumentException:Invalid recipe not recognized by any deployed server bundle plugin.

4) when user selects recipe option and proceeds without entering recipe details-The bundle creation wizard displays: 

javax.ejb.EJBException:java.lang.IllegalArgumentException: recipe == null -> java.lang.IllegalArgumentException:recipe == null


In all above scenarios, the bundle wizard displays the failure reason as expected. 

However it is not displaying error messages like "Please select a valid URL"/"Please enter the URL"/"Please select a valid recipe file to upload" etc.
Comment 5 Corey Welton 2010-07-20 21:21:35 EDT
*** Bug 616262 has been marked as a duplicate of this bug. ***
Comment 6 Corey Welton 2010-09-28 08:51:40 EDT
Triaged 24-Sept
Comment 7 Jay Shaughnessy 2010-12-14 09:40:15 EST
The messaging could still improve (like everything :) but until we get more requests for more work here I think we're good.  If necessary we can open a new BZ in the future.

Note You need to log in before you can comment on or make changes to this bug.