Bug 61145 - Traceback in neat when trying to configure isdn-card
Summary: Traceback in neat when trying to configure isdn-card
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-03-14 11:18 UTC by Inger Karin Haarbye
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-03 09:41:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Inger Karin Haarbye 2002-03-14 11:18:52 UTC
Description of Problem:

Hampton, beta2, running neat from <alt><F2> is not working at all. 
Running neat from terminal-window works, but when trying to configure 
my isdn-card I get traceback.

Version-Release number of selected component (if applicable):

redhat-config-network-0.9.12-1

How Reproducible:

tried twice with same result.

Steps to Reproduce:
1. "neat"
2. Hardware, trying to add isdn-card -> traceback
3. 

Actual Results:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1223, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 1060, in on_hardwareAddButton_clicked
    self.showHardwareDialog(type, false)
  File "/usr/sbin/neat", line 1122, in showHardwareDialog
    dialog = isdnHardwareDialog(hw)
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/isdnhardware.py", line 63, in __init__
    self.hydrate()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/isdnhardware.py", line 135, in hydrate
    self.xml.get_widget("adapterEntry").set_text(self.hw.Description)
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2145, in set_text
    _gtk.gtk_entry_set_text(self._o, text)
TypeError: gtk_entry_set_text, argument 2: expected string, None found


Expected Results:

Well...

Additional Information:
 
Teles 16.3C PnP isdn-card

Comment 1 Trond Eivind Glomsrxd 2002-03-28 20:41:25 UTC
Can you try 0.9.20 at http://people.redhat.com/teg/neat/?

Comment 2 Inger Karin Haarbye 2002-03-29 12:48:35 UTC
This is working now in Skipjack with redhat-config-network-0.9.18-1 and with     
redhat-config-network-0.9.20-1, I'm able to configure my isdn-card. I still have
to use   
terminal-window, <alt><F2> is not working for "neat". (- and Control-panel is
not   
working.)   
Still no GUI for isdn-dialing?

Comment 3 Inger Karin Haarbye 2002-03-29 13:08:46 UTC
I did find the GUI: neat-control. Nice! I can dial my ISDN ISP-provider with 
neat-control, but the "configure" button is not working.

Comment 4 Harald Hoyer 2002-04-03 09:41:44 UTC
with usermode-gtk-1.52-1, I can run neat from <alt><F2> 


Comment 5 Jay Turner 2002-04-03 15:47:37 UTC
Closing this out.


Note You need to log in before you can comment on or make changes to this bug.