Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 611486 - valgrind.x86_64 1:3.5.0-17.fc13 yum install fails unpacking archive
valgrind.x86_64 1:3.5.0-17.fc13 yum install fails unpacking archive
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: valgrind (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 08:13 EDT by tom.jenkinson
Modified: 2010-07-05 09:34 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-05 09:34:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tom.jenkinson 2010-07-05 08:13:58 EDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.4) Gecko/20100622 Fedora/3.6.4-1.fc13 Firefox/3.6.4

Valgrind won't install using yum on my Thinkpad T61. I tried yum install valgrind and it doesn't work. Also note that I tried yum install valgrind.i686 and this doesn;t work for the same error message - although it is the 64 bit version that I need.

tom@localhost ~]$ sudo yum install valgrind
Loaded plugins: presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package valgrind.x86_64 1:3.5.0-17.fc13 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

===============================================================================================================================================================================================================
 Package                                          Arch                                           Version                                                  Repository                                      Size
===============================================================================================================================================================================================================
Installing:
 valgrind                                         x86_64                                         1:3.5.0-17.fc13                                          fedora                                          19 M

Transaction Summary
===============================================================================================================================================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Total download size: 19 M
Installed size: 72 M
Is this ok [y/N]: y
Downloading Packages:
Setting up and reading Presto delta metadata
Processing delta metadata
Package(s) data still to download: 19 M
valgrind-3.5.0-17.fc13.x86_64.rpm                                                                                                                                                       |  19 MB     01:09     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : 1:valgrind-3.5.0-17.fc13.x86_64                                                                                                                                                         1/1 
Error unpacking rpm package 1:valgrind-3.5.0-17.fc13.x86_64
error: unpacking of archive failed on file /usr/bin/callgrind_annotate;4c31cbc8: cpio: open

Failed:
  valgrind.x86_64 1:3.5.0-17.fc13                                                                                                                                                                              

Complete!


Reproducible: Always

Steps to Reproduce:
1. sudo yum install valgrind
2.
3.
Actual Results:  
Install fails due to cpio error

Expected Results:  
It should have installed valgrind
Comment 1 Jakub Jelinek 2010-07-05 08:20:26 EDT
Perhaps full disk or some I/O error?
Works just fine here...
Comment 2 tom.jenkinson 2010-07-05 08:29:22 EDT
(In reply to comment #1)
> Perhaps full disk or some I/O error?
> Works just fine here...    

Hi Jakub,

The disk isn't full:
 df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/VolGroup-lv_root
                      46283768  40751320   3181344  93% /
tmpfs                  1541388       476   1540912   1% /dev/shm
/dev/sda1               495844     46001    424243  10% /boot
/dev/mapper/VolGroup-lv_home
                      44252296  17251320  24753092  42% /home


I decided to try to build the source for valgrind but that doesn't work as the GLIBC version is not supported. Looking through bugzilla it appears we are using a patched version of valgrind in our repo though?

Anyway, do you have further ideas on possible I/O error causes? I have tried this command several times now and consistently get the same error....
Comment 3 Jakub Jelinek 2010-07-05 08:37:29 EDT
Look at dmesg output, audit messages, etc.
You can also strace -f yum (or rpm) to see what error has been given on what syscall.

In any case, this isn't a bug in the rpm itself...
Comment 4 tom.jenkinson 2010-07-05 09:31:21 EDT
Hi Jakub,

This bug can be closed.

I did dmesg which showed nothing so I then tried strace which I needed to be installed. I then tried to install this and got the same error!

I rebooted the laptop and now can yum install them both.

Strange but true...

Thanks for looking into this for me,
Tom

Note You need to log in before you can comment on or make changes to this bug.