Bug 61152 - getfh failed: Operation not permitted
Summary: getfh failed: Operation not permitted
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils   
(Show other bugs)
Version: 7.2
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-14 14:32 UTC by Neal D. Becker
Modified: 2007-04-18 16:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-14 15:06:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neal D. Becker 2002-03-14 14:32:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Since installing all the latest RH7.2 updates nfs-utils seems to be
broken!  When booted the nfs server will not operate correctly, but
gives the above message.  If I do /sbin/service nfs stop and then start, then
it's fine!

nfs-utils-0.3.1-13.7.2.1

Here is my exports:

/usr  *.hns.com(rw,async) *.adg.labs.md.hnsnet(rw,async)
/disk1 *.hns.com(rw,async) *.adg.labs.md.hnsnet(rw,async)
/var/ftp/pub *(ro)


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot
2.
3.
	

Additional info:

Comment 1 Neal D. Becker 2002-03-14 14:38:15 UTC
This is interesting!  Notice that the first time, when it failed I see:

Mar 14 09:21:13 rpppc1 rpc.mountd: authenticated mount request from
10.84.192.253:661 for /disk1/nbecker (/disk1) 
Mar 14 09:21:13 rpppc1 rpc.mountd: getfh failed: Operation not permitted 

See the message gives the IP.

Now the second time, when it mounted OK:

Mar 14 09:22:49 rpppc1 rpc.mountd: authenticated mount request from
rpppc2.adg.labs.md.hnsnet:664 for /disk1/nbecker (/disk1) 

I wonder if that is significant?

Comment 2 Bob Matthews 2002-03-22 16:02:15 UTC
Should be fixed in the next release.  Can you pull the latest nfs-utils out of
rawhide and confirm that it is fixed?

ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/nfs-utils-0.3.3-2.i386.rpm

Comment 3 Kevin Croker 2003-01-07 11:41:27 UTC
As of 0.3.3-5 on 7.3, bug still exists.  I deleted the shared directory then
remade it, perhaps that caused the problem?  Hack solution of stopping and
starting resolved problem.


Note You need to log in before you can comment on or make changes to this bug.