Bug 611536 - python-virtualenv in epel-5-testing is not installable
python-virtualenv in epel-5-testing is not installable
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-virtualenv (Show other bugs)
el5
All Linux
low Severity medium
: ---
: ---
Assigned To: Steve Milner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-05 09:31 EDT by Stijn Hoop
Modified: 2010-07-21 16:05 EDT (History)
1 user (show)

See Also:
Fixed In Version: python-virtualenv-1.4.8-3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-21 16:05:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stijn Hoop 2010-07-05 09:31:01 EDT
Description of problem:

python-virtualenv in epel-5-testing is not installable

Version-Release number of selected component (if applicable):

[stijn@sandcat] <~> repoquery --enablerepo=epel-testing python-virtualenv
python-virtualenv-0:1.4.8-2.el5.noarch

How reproducible:

Always

Steps to Reproduce:

yum --enablerepo=epel-testing install python-virtualenv
  
Actual results:

Resolving Dependencies
--> Running transaction check
---> Package python-virtualenv.noarch 0:1.4.8-2.el5 set to be updated
--> Processing Dependency: python-setuptools-devel for package: python-virtualenv
--> Finished Dependency Resolution
python-virtualenv-1.4.8-2.el5.noarch from epel-testing has depsolving problems
  --> Missing Dependency: python-setuptools-devel is needed by package python-virtualenv-1.4.8-2.el5.noarch (epel-testing)
Error: Missing Dependency: python-setuptools-devel is needed by package python-virtualenv-1.4.8-2.el5.noarch (epel-testing)


Expected results:

package should be installed.

Additional info:

As far as I can see this is simply an unnecessary dependency in the spec file?
Comment 1 Steve Milner 2010-07-05 11:44:37 EDT
Thanks, I'm taking a quick look now.
Comment 2 Steve Milner 2010-07-05 11:58:16 EDT
It does seem like it isn't needed. I just force installed it on my centos box and it worked fine without it. I *think* at one point it was needed but I'll drop the install dep on setuptools-devel.
Comment 3 Stijn Hoop 2010-07-05 17:03:21 EDT
It's probably needed in Fedora though? At least on my Fedora 12 machine it seems the dependency is there. Probably got split out somewhere between RHEL 5 and Fedora. Thanks for looking at it quickly!
Comment 4 Steve Milner 2010-07-07 14:48:54 EDT
Sure no problem! I'll do a dist check so if it is el5 then it doesn't require it as a dependency.

I'm making the change now and will have it requested for testing shortly.
Comment 6 Steve Milner 2010-07-07 15:03:10 EDT
I just tested it against my CentOS 5 box and it didn't seem to have an issue. The resulting Fedora build seems to be good as well. I'm going to request this get push to testing.


[steve@gibson ~]$ sudo rpm -e python-virtualenv
[steve@gibson ~]$ sudo rpm -q python-setuptools-devel
package python-setuptools-devel is not installed

[steve@gibson ~]$ sudo yum localinstall --nogpgcheck python-virtualenv-1.4.8-3.el5.noarch.rpm 
Loaded plugins: fastestmirror
Setting up Local Package Process
Examining python-virtualenv-1.4.8-3.el5.noarch.rpm: python-virtualenv-1.4.8-3.el5.noarch
Marking python-virtualenv-1.4.8-3.el5.noarch.rpm to be installed
Loading mirror speeds from cached hostfile
 * addons: mirror.sanctuaryhost.com
 * base: mirror.sanctuaryhost.com
 * epel: www.gtlib.gatech.edu
 * extras: centos.mbni.med.umich.edu
 * updates: mirror.sanctuaryhost.com
Excluding Packages in global exclude list
Finished
Resolving Dependencies
--> Running transaction check
---> Package python-virtualenv.noarch 0:1.4.8-3.el5 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package
      Arch      Version          Repository                                Size
================================================================================
Installing:
 python-virtualenv
      noarch    1.4.8-3.el5      /python-virtualenv-1.4.8-3.el5.noarch     0.0 

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade       0 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : python-virtualenv                                        1/1 

Installed:
  python-virtualenv.noarch 0:1.4.8-3.el5                                        

Complete!
[steve@gibson ~]$
Comment 7 Fedora Update System 2010-07-07 15:11:55 EDT
python-virtualenv-1.4.8-3.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-virtualenv-1.4.8-3.el5
Comment 8 Fedora Update System 2010-07-09 01:55:05 EDT
python-virtualenv-1.4.8-3.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-virtualenv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-virtualenv-1.4.8-3.el5
Comment 9 Stijn Hoop 2010-07-09 03:25:40 EDT
Works perfectly, thanks!
Comment 10 Fedora Update System 2010-07-21 16:05:39 EDT
python-virtualenv-1.4.8-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.