Bug 61155 - /usr/sbin/junkbuster not started on bootup by script K09junkbuster. Have to start manually with nohup.
Summary: /usr/sbin/junkbuster not started on bootup by script K09junkbuster. Have to s...
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: junkbuster (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-14 15:08 UTC by Newton Hammet
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-25 20:24:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Requested by Karsten, output logfile: /etc/init.d/junkbuster (3.99 KB, text/plain)
2002-03-25 20:24 UTC, Newton Hammet
no flags Details

Description Newton Hammet 2002-03-14 15:08:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
note that /usr/sbin/junkbuster is not started when boot to runlevel 5.
Also note that the script has an error where the return code from 
daemon is reported as ?$ instead of $?.
I was able to successfully start /usr/sbin/junkbuster by doing the
following:
1. Create my own /etc/junkbuster/blocklist
  (move the original to: /etc/junkbuster/blocklist.orig)
2. Write my own script that uses "nohup" to start it the following
  manner:

nohup /usr/sbin/junkbuster /etc/junkbuster/config >/dev/null \ 2>/dev/null &

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Simply reboot the machine. (from power-off, or any other state)
2. check process table (junkbuster will not be running)
3.
	

Actual Results:  /usr/sbin/junkbuster is not running.

Expected Results:  1. /usr/sbin/junkbuster should be running.
2. It should have been reported on bootup with the green 'OK' status.
 

Additional info:

Name        : junkbuster                   Relocations: (not relocateable)
Version     : 2.0.2                             Vendor: Red Hat, Inc.
Release     : 28                            Build Date: Sat 07 Jul 2001 03:03:32
PM CDT
Install date: Thu 21 Feb 2002 06:48:03 AM CST      Build Host:
stripples.devel.redhat.com
Group       : Applications/System           Source RPM:
junkbuster-2.0.2-28.src.rpm
Size        : 299205                           License: GPL

acf50dd5ec3633a1a5876e8c5fa2efbe  /etc/rc5.d/K09junkbuster

Comment 1 Karsten Hopp 2002-03-24 23:28:05 UTC
junkbuster will not be started in any runlevel unless you tell it to do
otherwise by executing 'chkconfig -level 345 junkbuster on'
The return code of the stop() function will be fixed in the next release.


Comment 2 Newton Hammet 2002-03-25 02:44:26 UTC
Your suggestion did not fix the problem.
I ran 'chkconfig --level 345 junkbuster on', rebooted, and the problem
still exists.

bootup messages show a green 'ok' saying junkbuster started, the lock file
is created , but junkbuster is still not running as verified by:
ps -ef|grep junk
after login after reboot.

If you need additional information I can supply it.

Comment 3 Karsten Hopp 2002-03-25 09:07:31 UTC
can you please run 'sh -x /etc/initd./junkbuster restart 2>&1 | tee /tmp/junkbuster_log'
and send me the output (/tmp/junkbuster_log)  ?


Comment 4 Newton Hammet 2002-03-25 20:24:44 UTC
Created attachment 50244 [details]
Requested by Karsten, output logfile: /etc/init.d/junkbuster


Note You need to log in before you can comment on or make changes to this bug.