Bug 6117 - lpr does not print with local printer. Worked in 6.0
lpr does not print with local printer. Worked in 6.0
Product: Red Hat Linux
Classification: Retired
Component: lpr (Show other bugs)
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 1999-10-20 00:32 EDT by jstrand1
Modified: 2014-03-16 22:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 1999-11-08 13:45:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jstrand1 1999-10-20 00:32:42 EDT
I currently use an HP DeskJet712C printer, and although it
is only partitally supported, with the drivers from
httptech.com, I was able to get the printer to work in black
and white.  I would add an entry to printerdb in
rhl-printfilters, then add the printer (which was detected
on lp0) with printtool (with some extra options telling it
what driver to use).  This worked perfectly in 6.0, but now
when I restart lpd and try to print a test page, it gets
hung up and does not print.

Note, I can print via other means, so it is not the
printer.  However, the functionality provided with RedHat
6.0 is missed.
Comment 1 Bill Nottingham 1999-10-20 00:42:59 EDT
Do you have the line:

alias parport_lowlevel parport_pc

in /etc/conf.modules?
Comment 2 Bill Nottingham 1999-10-20 10:10:59 EDT
Did you recompile ghostscript with the different driver you're using
Comment 3 Bill Nottingham 1999-10-29 16:48:59 EDT
It's not running out of disk space, correct?

What happens if you install the rhs-printfilters from 6.0?
Comment 4 Bill Nottingham 1999-11-01 13:31:59 EST
Try installing the rhs-printfilters from 6.0, and copying
/usr/lib/rhs/rhs-printfilters/master-filter to

Does that solve the problem?

What does the huge file in /tmp look like?

------- Additional Comments From   11/04/99 12:15 -------
In order to get the parallel port detected using the 2.2.12-20 kernel,
you must have the following conditions met:

1) Have "alias parport_lowlevel parport_pc" in /etc/conf.modules
2) Use a DMA parallel port mode. VERY IMPORTANT!

This is of course fixed in the 2.2.12-27 kernel. None of the above
apply for this kernel.

------- Additional Comments From   11/04/99 20:14 -------
add:  parport_lowlevel parport_pc  to /etc/conf.modules
Comment 5 Bill Nottingham 1999-11-08 13:45:59 EST
OK, this should be fixed (the pbm2ppa problem) with
rhs-printfilters-1.58, which will be in the next Raw Hide

Note You need to log in before you can comment on or make changes to this bug.