Bug 611705 - Notifications settings made in xfce4-notifyd-config fully ignored
Notifications settings made in xfce4-notifyd-config fully ignored
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xfce4-notifyd (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 04:28 EDT by Pavel Alexeev
Modified: 2010-07-06 12:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-06 04:47:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Alexeev 2010-07-06 04:28:53 EDT
Description of problem:
I run xfce4-notifyd-config, but any settings made there fully ignored and notifications appeared at right top corner on black background.

Version-Release number of selected component (if applicable):
$ rpm -qf `which xfce4-notifyd-config`
xfce4-notifyd-0.1.0-3.fc12.i686

How reproducible:
Always.
Comment 1 Christoph Wickert 2010-07-06 04:47:04 EDT
xfce4-notifyd doesn't have a black theme, so what you see is notification-daemon from GNOME. The problem is that ATM it is not able to switch die notification service due to bug 484945.

Two options:
- As d-bus will always use the service that was installed last, you can uninstall and reinstall xfce4-notifyd.
- Edit /usr/share/dbus-1/services/org.freedesktop.Notifications.service and the Exec= line to execute xfce4-notifyd.
Comment 2 Pavel Alexeev 2010-07-06 05:57:43 EDT
Thank you very much for the answer. And workarounds also very usefull.
Reinstall does not change this linee in it file. I'll try rewrite it manually.
Comment 3 Christoph Wickert 2010-07-06 06:30:32 EDT
Another option is to simply remove /usr/share/dbus-1/services/org.freedesktop.Notifications.service.
Comment 4 Pavel Alexeev 2010-07-06 12:13:03 EDT
Second solution work great, thank you.

Note You need to log in before you can comment on or make changes to this bug.