Bug 611714 - Cannot de-select Hanja lock in applet menu
Summary: Cannot de-select Hanja lock in applet menu
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
(Show other bugs)
Version: 12
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 608988
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-06 09:17 UTC by fujiwara
Modified: 2010-07-13 07:34 UTC (History)
4 users (show)

Fixed In Version: ibus-1.3.6-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 608988
Environment:
Last Closed: 2010-07-08 18:29:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description fujiwara 2010-07-06 09:17:44 UTC
+++ This bug was initially created as a clone of Bug #608988 +++

Description of problem:

When using Korean Input Method of iBus, once select Hanja lock, never de-select again.

Version-Release number of selected component (if applicable):

RHEL Version:Red Hat Enterprise Linux Workstation release 6.0 Beta (Santiago)
Kernel:2.6.32-37.el6.x86_64
Package:
ibus-1.3.3-1.el6.x86_64
ibus-hangul-1.3.0.20100329-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Add Korean Input Method
2. Trun iBus on in an application
3. Mouse click on the Korean iBus icon and select Hanja lock
4. Mouse click on the Korean iBus icon and de-select Hanja lock
  
Actual results:

De-selecting is disabled.

Expected results:

Is this spec?

Additional info:

--- Additional comment from pm-rhel@redhat.com on 2010-06-29 02:31:28 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from pm-rhel@redhat.com on 2010-06-29 02:42:52 EDT ---

This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

--- Additional comment from dueno@redhat.com on 2010-06-30 00:14:51 EDT ---

I guess this is a bug of ibus not ibus-hangul.  I've just filed the bug at the upstream issue tracker with a patch:

http://code.google.com/p/ibus/issues/detail?id=987

--- Additional comment from tfujiwar@redhat.com on 2010-07-06 05:11:50 EDT ---

Thanks for the patch and upstream. I verified the patch.
rf. rawhide is fixed.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2297472

Comment 1 Fedora Update System 2010-07-06 10:31:59 UTC
ibus-1.3.6-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/ibus-1.3.6-1.fc13

Comment 2 Fedora Update System 2010-07-06 10:46:28 UTC
ibus-1.3.6-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-1.3.6-1.fc12

Comment 3 Fedora Update System 2010-07-06 17:05:53 UTC
ibus-1.3.6-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-1.3.6-1.fc13

Comment 4 Fedora Update System 2010-07-06 17:22:05 UTC
ibus-1.3.6-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/ibus-1.3.6-1.fc12

Comment 5 Fedora Update System 2010-07-08 18:29:33 UTC
ibus-1.3.6-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2010-07-13 07:34:28 UTC
ibus-1.3.6-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.