Bug 61174 - TypeError after partial read
TypeError after partial read
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-14 15:54 EST by Todd Warner
Modified: 2015-01-07 18:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-20 14:04:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Warner 2002-03-14 15:54:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.7) Gecko/20011226

Description of problem:
After a partial read error, I get a TypeError (not enough args passed).
Couldn't find the issue in 5 mins... so passing along here.

Version-Release number of selected component (if applicable):


How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. The client stalled, mid-download (due to Chip bouncing the proxies).
2. I cancelled
3. See results below:
	

Actual Results:  [root@trixie rhn]# up2date
Traceback (innermost last):
  File "/usr/share/rhn/up2date_client/gui.py", line 696, in doRetrieval
    self.setRetrievalProgress)
  File "/usr/share/rhn/up2date_client/up2date.py", line 1120, in getPackage
    buffer = doCall(packageSource.getPackage, pkg, msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 400, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 124, in getPackage
    package = source.getPackage(pkg, MsgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 557, in getPackage
    buffer = self._readFD(fd, size, filePath, progressCallback = progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 509, in _readFD
    raise PartialReadError()
TypeError: not enough arguments; expected 1, got 0


Expected Results:  Should have simply exited :)

Additional info:

[taw@trixie up2date]$ rpm -qa| grep up2date
up2date-2.7.42-7.x.2
up2date-gnome-2.7.42-7.x.2
Comment 1 Adrian Likins 2002-03-20 14:04:48 EST
fixed in cvs (circa 2.7.48 or so)

Note You need to log in before you can comment on or make changes to this bug.