Bug 611740 - Perf: Huge contention on RHQ_RESOURCE_ERROR
Summary: Perf: Huge contention on RHQ_RESOURCE_ERROR
Status: CLOSED CURRENTRELEASE
Alias: None
Product: RHQ Project
Classification: Other
Component: Core Server   
(Show other bugs)
Version: 3.0.0
Hardware: All
OS: Linux
low
medium vote
Target Milestone: ---
: ---
Assignee: RHQ Project Maintainer
QA Contact: Mike Foley
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rhq-perf
TreeView+ depends on / blocked
 
Reported: 2010-07-06 10:29 UTC by Heiko W. Rupp
Modified: 2014-06-02 19:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 19:06:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Oracle EM showing TM contention (55.43 KB, image/png)
2010-07-06 10:30 UTC, Heiko W. Rupp
no flags Details
Oracle EM showing top activity (42.24 KB, image/png)
2010-07-06 10:30 UTC, Heiko W. Rupp
no flags Details

Description Heiko W. Rupp 2010-07-06 10:29:19 UTC
There is huge contention on inserting into RHQ resource error table - looks like from the (only 700 rows) like those may come from multiple plugins sending reports about ResourceComponent unable to start at around the same time (as with the perf plugin)

Statement is 

insert into RHQ_RESOURCE_ERROR (TIME_OCCURRED, RESOURCE_ID, ERROR_TYPE, SUMMARY, DETAIL, ID) values (:1 , :2 , :3 , :4 , :5 , :6 )

See screenshot (s)

Comment 1 Heiko W. Rupp 2010-07-06 10:30:05 UTC
Created attachment 429733 [details]
Oracle EM showing TM contention

Comment 2 Heiko W. Rupp 2010-07-06 10:30:40 UTC
Created attachment 429734 [details]
Oracle EM showing top activity


Note You need to log in before you can comment on or make changes to this bug.