Bug 611759 - Deleting some 1000 packages retrieves 500-error
Summary: Deleting some 1000 packages retrieves 500-error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: WebUI   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
: 650096 (view as bug list)
Depends On:
Blocks: space16
TreeView+ depends on / blocked
 
Reported: 2010-07-06 12:29 UTC by Gerrit Slomma
Modified: 2011-08-19 09:58 UTC (History)
2 users (show)

Fixed In Version: spacewalk-java-1.1.31-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-19 09:58:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output in catalina of corresponding time time. (8.12 KB, application/octet-stream)
2010-07-06 12:30 UTC, Gerrit Slomma
no flags Details

Description Gerrit Slomma 2010-07-06 12:29:19 UTC
Description of problem:

When deleting a channel packages becoming orphaned. Upon deleting those packages - 2632 in my case - via "Manage Software Channels"=>"Manage Software Packages" after some time - hand-stopped 120 seconds - a 500-error is retrieved.

Version-Release number of selected component (if applicable):

current spacewalk-release for RHEL5

How reproducible:

Every time.

Steps to Reproduce:
1. select all orphaned packages via "Packages in no channel" "Select All"
2. order deletion
3. wait for 500-error
  
Actual results:

500-error as a cause of a jk-timeout

Expected results:

packages are deleted

Additional info:

/var/lib/httpd/error.log
(...)
[Tue Jul 06 13:56:41 2010] [error] (70007)The timeout specified has expired: ajp_ilink_receive() can't receive header

catalina.out is attached

Comment 1 Gerrit Slomma 2010-07-06 12:30:50 UTC
Created attachment 429760 [details]
output in catalina of corresponding time time.

Comment 2 Gerrit Slomma 2010-07-06 12:34:47 UTC
Deletion of 25 packages (4 seconds) and 500 packages (14 seconds) was succesfull.
But that could be a bit gruesome to delete >5k packages that way.

Comment 3 Gerrit Slomma 2010-07-06 12:37:27 UTC
I worked it down to under 2k: 1999 packages deleted in 100 seconds.

Comment 4 Michael Mráka 2010-07-07 08:36:00 UTC
Reassigning to WebUI component.

Comment 5 Jan Pazdziora 2010-11-19 16:05:04 UTC
Mass-moving to space13.

Comment 6 Miroslav Suchý 2011-04-11 07:33:43 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 7 Miroslav Suchý 2011-04-11 07:37:16 UTC
We did not have time for this one during Spacewalk 1.4 time frame. Mass moving to Spacewalk 1.5.

Comment 8 Jan Pazdziora 2011-07-20 11:52:05 UTC
Aligning under space16.

Comment 9 Clifford Perry 2011-08-05 14:38:56 UTC
*** Bug 650096 has been marked as a duplicate of this bug. ***

Comment 10 Michael Mráka 2011-08-19 09:58:40 UTC
This issue has been fixed some time ago in bug 533190.

commit bb71fe8f8d6cef4d938b271a65c408ad53974a9f
    533190 - fixing issue where deleting more than 1000 errata would throw a database error

Closing this bug, feel free to reopen it if you disagree.


Note You need to log in before you can comment on or make changes to this bug.