Bug 61181 - database indexes gets corrupted
database indexes gets corrupted
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: openldap (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Fenlason
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-14 17:22 EST by stefan+rhbugs
Modified: 2014-08-31 19:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 12:37:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stefan+rhbugs 2002-03-14 17:22:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)

Description of problem:
I'm running openldap-2.0.11-13 on RH7.1, partially upgraded to RH7.2.

The database contains a couple of thousand entries, used for login 
autentication and email routing. One day, some email bounced, and further 
investigation revealed that ldap searches failed with some filters. I.e. (but 
not specific to)  (&(objectClass=*)(uid=joe))
The same query had worked perfectly before. Also, choosing another uid 
sometimes returned results. Searching for only uid=joe also returned results.

Anyway, by using slapcat/slapadd, the indexes were regenerated, and the same 
query works OK.

This has now happened twice in a month. Since regenerating the indexes solves 
the problem, I guess they become corrupted somehow.



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Actual Results:  specific queries failed, seems related to the search filter

Expected Results:  the query should succeed.

Additional info:

I think this is a nasty bug because it happens unpredictably and does not 
affect all records. I.e. there is no way of verifying if the indexes are 
corrupt, until some user reports that his account does not work as it should.

This gentleman seems to have the same problem:
http://www.openldap.org/lists/openldap-software/200111/msg00593.html
Comment 1 John Morrissey 2002-04-21 16:05:22 EDT
This sounds like 60916; see my comments there.
Comment 2 Bill Nottingham 2006-08-07 15:13:08 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.
Comment 3 Bill Nottingham 2006-10-18 12:37:01 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.