Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 611826 - SELinux is preventing /sbin/dhclient "read" access on /var/log/h3c-linux1x/slog20100706.log.
SELinux is preventing /sbin/dhclient "read" access on /var/log/h3c-linux...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:9f0305994ee...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 11:14 EDT by sbzlyessit
Modified: 2010-07-07 04:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 04:32:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sbzlyessit 2010-07-06 11:14:53 EDT
Summary:

SELinux is preventing /sbin/dhclient "read" access on
/var/log/h3c-linux1x/slog20100706.log.

Detailed Description:

[dhclient has a permissive type (dhcpc_t). This access was not denied.]

SELinux denied access requested by dhclient. It is not expected that this access
is required by dhclient and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:var_log_t:s0
Target Objects                /var/log/h3c-linux1x/slog20100706.log [ file ]
Source                        dhclient
Source Path                   /sbin/dhclient
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dhclient-4.1.1-22.P1.fc13
Target RPM Packages           
Policy RPM                    selinux-policy-3.7.19-28.fc13
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux sbzlyessit 2.6.33.5-124.fc13.i686 #1 SMP Fri
                              Jun 11 09:48:40 UTC 2010 i686 i686
Alert Count                   1
First Seen                    Tue 06 Jul 2010 10:53:55 PM CST
Last Seen                     Tue 06 Jul 2010 10:53:55 PM CST
Local ID                      b3eff472-cd87-4e4c-971c-e2a07ab30733
Line Numbers                  

Raw Audit Messages            

node=sbzlyessit type=AVC msg=audit(1278428035.238:100): avc:  denied  { read } for  pid=25136 comm="dhclient" path="/var/log/h3c-linux1x/slog20100706.log" dev=sda3 ino=131381 scontext=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:var_log_t:s0 tclass=file

node=sbzlyessit type=SYSCALL msg=audit(1278428035.238:100): arch=40000003 syscall=11 success=yes exit=0 a0=9d30128 a1=9d32190 a2=9d31940 a3=9d32190 items=0 ppid=25135 pid=25136 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=7 comm="dhclient" exe="/sbin/dhclient" subj=unconfined_u:system_r:dhcpc_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,dhclient,dhcpc_t,var_log_t,file,read
audit2allow suggests:

#============= dhcpc_t ==============
allow dhcpc_t var_log_t:file read;
Comment 1 Miroslav Grepl 2010-07-07 04:32:45 EDT
Which tool are you using to launch ifup/dhclient? It looks like leaked file descriptors from this tool.

The tool needs to close all file descriptors before execing these commands.

You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Note You need to log in before you can comment on or make changes to this bug.