This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 611836 - Backend not running as expected (yumex will close)
Backend not running as expected (yumex will close)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 11:51 EDT by rvcsaba
Modified: 2012-08-22 12:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: yumex-2.9.9-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 16:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description rvcsaba 2010-07-06 11:51:09 EDT
Description of problem:

Backend not running as expected (yumex will close)


Version-Release number of selected component (if applicable):

rpm -q yumex
yumex-2.9.9-1.fc13.noarch


How reproducible:

allways


Steps to Reproduce:

1. start yumex
  

Actual results:

yumex -d --debuglevel=9
running
Current Settings
    autorefresh: True
    branding_title: 'Yum Extender'
    color_install: 'darkgreen'
    color_normal: 'black'
    color_obsolete: 'blue'
    color_update: 'red'
    debug: True
    disable_netcheck: False
    disable_repo_page: False
    history_limit: 15
    plugins: True
    proxy: ''
    recentdays: 14
    repo_exclude: ['debug', 'source']
    use_sortable_view: False
    win_height: 468
    win_sep: 162
    win_width: 954
    yum_conf: '/etc/yum.conf'
    yumdebuglevel: 9
/usr/lib/python2.6/site-packages/guihelpers/__init__.py:199: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
Can't detect the network connection state
DEBUG: Getting package lists - BEGIN
Starting yum child process
DEBUG: Initialize yum backend - BEGIN
YUM: Traceback (most recent call last):
YUM:   File "/usr/share/yumex/yumex-yum-backend", line 55, in <module>
YUM:     if len(sys.sargv) > 3:
YUM: AttributeError: 'module' object has no attribute 'sargv'
ERROR: Fatal Error : backend-not-running
ERROR: backend not running as expected (yumex will close)
DEBUG: Quiting the program !!!
yum backend process is ended
DEBUG: Backend reset completted
Program Terminated


Expected results:

work correctly


Additional info:

I use version 2.9.9 from Koji.
Comment 1 dominique 2010-07-06 14:51:02 EDT
Same problem with rawhide and yumex-2.9.9-1.fc14.noarch
Comment 2 Tim Lauridsen 2010-07-07 03:24:45 EDT
Looks like a stupid typo, i will make a new release very soon

Fixed upstream
Comment 3 Fedora Update System 2010-07-07 03:50:38 EDT
yumex-2.9.9-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/yumex-2.9.9-2.fc13
Comment 4 rvcsaba 2010-07-07 03:56:36 EDT
(In reply to comment #2)
 
> Fixed upstream    

Thank you, Tim!
Comment 5 dominique 2010-07-07 09:09:34 EDT
Ok that work for me, thank...
Comment 6 Fedora Update System 2010-07-07 13:51:46 EDT
yumex-2.9.9-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yumex'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/yumex-2.9.9-2.fc13
Comment 7 Fedora Update System 2010-07-13 16:43:14 EDT
yumex-2.9.9-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 diods 2011-05-27 09:38:31 EDT
Same problem with with fedora 15 and yumex-3.0.3-1.fc15
Comment 9 Tim Lauridsen 2011-05-27 13:05:36 EDT
(In reply to comment #8)
> Same problem with with fedora 15 and yumex-3.0.3-1.fc15

I cant be same issue as in this report.

please open a new report and attach the output from

yumex -d --debuglevel=9
Comment 10 Josh 2012-05-25 07:59:02 EDT
I have same issue with yum 3.0.5-2.fc16  on Fedora x86_64 after upgrading to kernel 3.3.6

yumex -d --debuglevel=9 output:

[josh@Amathor ~]$ yumex -d --debuglevel=9
/usr/share/themes/Black-Amber-1/gtk-2.0/gtkrc:217: Unable to locate image file in pixmap_path: "Others/bg.png"

(yumex:2079): Gtk-WARNING **: Unable to locate theme engine in module_path: "murrine",
04:56:52 : DEBUG - Current Yumex Settings:
04:56:52 : DEBUG -     autorefresh: True
04:56:52 : DEBUG -     branding_title: 'Yum Extender'
04:56:52 : DEBUG -     bugzilla_url: 'https://bugzilla.redhat.com/show_bug.cgi?id='
04:56:52 : DEBUG -     color_downgrade: 'goldenrod'
04:56:52 : DEBUG -     color_install: 'darkgreen'
04:56:52 : DEBUG -     color_normal: 'black'
04:56:52 : DEBUG -     color_obsolete: 'blue'
04:56:52 : DEBUG -     color_update: 'red'
04:56:52 : DEBUG -     debug: True
04:56:52 : DEBUG -     disable_netcheck: False
04:56:52 : DEBUG -     disable_repo_page: False
04:56:52 : DEBUG -     history_limit: 15
04:56:52 : DEBUG -     no_gpg_check: False
04:56:52 : DEBUG -     plugins: True
04:56:52 : DEBUG -     proxy: ''
04:56:52 : DEBUG -     recentdays: 14
04:56:52 : DEBUG -     repo_exclude: ['debug', 'source']
04:56:52 : DEBUG -     show_newest_only: True
04:56:52 : DEBUG -     skip_broken: False
04:56:52 : DEBUG -     typeahead_search: False
04:56:52 : DEBUG -     use_sortable_view: False
04:56:52 : DEBUG -     use_sudo: False
04:56:52 : DEBUG -     win_height: 600
04:56:52 : DEBUG -     win_sep: 300
04:56:52 : DEBUG -     win_width: 1000
04:56:52 : DEBUG -     yum_conf: '/etc/yum.conf'
04:56:52 : DEBUG -     yumdebuglevel: 9
/usr/lib/python2.7/site-packages/guihelpers/__init__.py:256: GtkWarning: gtk_scrolled_window_add(): cannot add non scrollable widget use gtk_scrolled_window_add_with_viewport() instead
  self.add_from_file(filename)
04:56:52 : DEBUG - network interface wlan1 (rt2800usb) is connected
04:56:52 : DEBUG - network interface wlan1 (rt2800usb) is connected
04:56:53 : INFO - Connected to an network
04:56:53 : DEBUG - Getting package lists - BEGIN   <yumexgui.populate_package_cache>
04:56:53 : DEBUG - network interface wlan1 (rt2800usb) is connected
04:56:53 : INFO - Starting yum child process
04:56:53 : DEBUG - Initialize yum backend - BEGIN   <yum_backend.setup>
04:56:53 : DEBUG - Setup START   <yum_backend.setup>
04:56:53 : INFO - YUM: The value for the SHELL variable was not found the /etc/shells file
04:56:54 : ERROR - ERROR: Fatal Error : backend-not-running
04:56:54 : ERROR - ERROR: backend not running as expected (yumex will close)
04:56:54 : DEBUG - Quiting the program !!!   <yum_backend.quit>
04:56:54 : INFO - yum backend process is ended
04:56:54 : DEBUG - Backend reset completed   <yum_backend.quit>
04:56:54 : DEBUG - Quiting the program !!!   <yum_backend.quit>
04:56:54 : INFO - yum backend process is ended
04:56:54 : DEBUG - Backend reset completed   <yum_backend.quit>
Program Terminated
Comment 11 Josh 2012-05-25 08:19:59 EDT
(In reply to comment #10)
A side note, running the command  "sudo yumex --root" will allow yumex to start and run 100% correctly.  My other computer experianced the same issue, however it's odd, yumex was working just fine yesterday on both computers, and I have done nothing to either of them (havent installed, updated, or uninstalled) anything since then, and now they are both broke.. 0.o
Comment 12 Luis Lain 2012-06-04 06:48:02 EDT
(In reply to comment #10)

I have solved downgrading yumex to 3.0.4:


yum downgrade yumex
Loaded plugins: langpacks, presto, refresh-packagekit
fedora/group_gz                                          | 431 kB     00:00     
updates/group_gz                                         | 435 kB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package yumex.noarch 0:3.0.4-1.fc16 will be a downgrade
---> Package yumex.noarch 0:3.0.5-2.fc16 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch             Version                Repository        Size
================================================================================
Downgrading:
 yumex           noarch           3.0.4-1.fc16           fedora           355 k

Transaction Summary
================================================================================
Downgrade  1 Package

Total download size: 355 k
Is this ok [y/N]: y
Downloading Packages:
yumex-3.0.4-1.fc16.noarch.rpm                            | 355 kB     00:01     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : yumex-3.0.4-1.fc16.noarch                                    1/2 
  Cleanup    : yumex-3.0.5-2.fc16.noarch                                    2/2 
  Verifying  : yumex-3.0.4-1.fc16.noarch                                    1/2 
  Verifying  : yumex-3.0.5-2.fc16.noarch                                    2/2 

Removed:
  yumex.noarch 0:3.0.5-2.fc16                                                   

Installed:
  yumex.noarch 0:3.0.4-1.fc16                                                   

Complete!
Comment 13 Darr247 2012-08-22 11:36:00 EDT
While the cited error is what shows in the popup dialog, I believe this error currently stems from the preceeding 'info' line:

YUM: Error executing command as another user: Not authorized
Comment 14 Tim Lauridsen 2012-08-22 12:44:10 EDT
Could you please make a new bugzilla report, this is a old closed report.

yumex-3.0.5 is using polkit for lauching the backend as root.

earlier version uses consolehelper.

sudo yumex --root run the backend directly, so it will be not be affected by problems with starting the backend as root, using polkit.

Note You need to log in before you can comment on or make changes to this bug.