Bug 611838 - powering down guest causes network connection problem with host for 20-50 seconds
powering down guest causes network connection problem with host for 20-50 sec...
Status: CLOSED DUPLICATE of bug 571991
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libvirt (Show other bugs)
5.5
All Linux
low Severity high
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-07-06 11:54 EDT by olaf
Modified: 2010-11-09 08:33 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-13 08:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description olaf 2010-07-06 11:54:48 EDT
Description of problem:
When I power down a guest in virt-manager then I cannot connect to the host machine for 20-50 seconds.
The guests are connected using bridged networking.

Version-Release number of selected component (if applicable):
kvm-83-164.12
kmod-kvm-83-164.12
kernel-2.6.18-194.8.1.el5

Host OS: CentOS 5.5, x86_64
Guest OS: CentOS 5.4, Windows XP

How reproducible:
Always

Steps to Reproduce:
Create and install a guest with bridged networking. Next power down the guest OS.

  
Actual results:
The current connections to host are broken and it is even impossible to ping the host for 20-50 seconds.

Expected results:
No impact on host networking.

Additional info:

Here are described similar problems in Debian and Ubuntu:

http://kerneltrap.org/mailarchive/linux-kvm/2010/4/21/6261001/thread

https://bugs.launchpad.net/ubuntu/+source/qemu-kvm/+bug/584048

In /var/log/messages I see:
Jul  6 17:21:39 daisy kernel: br0: port 2(vnet0) entering disabled state
Jul  6 17:21:39 daisy kernel: device vnet0 left promiscuous mode
Jul  6 17:21:39 daisy kernel: br0: port 2(vnet0) entering disabled state
Comment 1 olaf 2010-07-12 11:07:16 EDT
It seems that probable cause is described in bug #571991
Comment 2 olaf 2010-07-12 15:53:30 EDT
I was able to fix this problem applying patch from bug #571991
Comment 3 Michael S. Tsirkin 2010-07-13 07:36:15 EDT
The issue here that somehow, tun got to be the first interface on the bridge.
So bridge gets the mac from tun, when we disconnect
this tun mac changes.
In addition to the patch suggested, we could connect eth0 first, and
this issue will go away.

Since libvirt does the bridge setup, this needs to be fixed there.
Changing component appropriately.
Comment 4 Daniel Berrange 2010-07-13 08:05:31 EDT

*** This bug has been marked as a duplicate of bug 571991 ***

Note You need to log in before you can comment on or make changes to this bug.