Bug 611872 - [RHEL6][Kernel] kmemleak: 1631 new suspected memory leaks
Summary: [RHEL6][Kernel] kmemleak: 1631 new suspected memory leaks
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Larry Woodman
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 846704
TreeView+ depends on / blocked
 
Reported: 2010-07-06 18:39 UTC by Jeff Burke
Modified: 2013-02-06 20:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-06 20:20:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Burke 2010-07-06 18:39:59 UTC
Description of problem:
 While running the kernel-debug variant of 2.6.32-42.el6 I noticed the following message from dmesg:

kmemleak: 1631 new suspected memory leaks (see /sys/kernel/debug/kmemleak)

Version-Release number of selected component (if applicable):
2.6.32-42.el6

How reproducible:
Always 

Steps to Reproduce:
1. Boot the i386 2.6.32-42.el6 kernel-debug, run dmesg
  
Additional info:
Not sure of the actual impact of this message but it should be investigated to understand the potential leaks.

Comment 2 Larry Woodman 2010-07-13 12:06:22 UTC
This is the only message that we get???

Larry

Comment 4 Larry Woodman 2010-07-13 15:44:31 UTC
Probably should assign this to Jason at least until we figure out if there is a real problem and where it is.

Larry

Comment 5 RHEL Product and Program Management 2010-07-15 14:03:38 UTC
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release. It has
been denied for the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **

Comment 6 RHEL Product and Program Management 2011-10-07 15:07:52 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 7 Jeff Burke 2013-02-06 19:55:20 UTC
Larry,
 I don't believe this is an issue any longer. Recent kernels have kmemleak disabled.

From dmesg:

 kmemleak: Kernel memory leak detector disabled

Best,
Jeff

Comment 8 Larry Woodman 2013-02-06 20:20:34 UTC
Close because RHEL6 kernels have kmemleak disabled.

Larry


Note You need to log in before you can comment on or make changes to this bug.