Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 611888 - [abrt] crash in eekboard-0.0.4-1.fc13: do_row: Process /usr/bin/eekboard was killed by signal 11 (SIGSEGV)
[abrt] crash in eekboard-0.0.4-1.fc13: do_row: Process /usr/bin/eekboard was ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eekboard (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
abrt_hash:a377bffaa3624dd28c74e804498...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 15:03 EDT by Mika Kuusela
Modified: 2010-07-30 04:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: eekboard-0.0.4-2.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-30 04:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (90.72 KB, text/plain)
2010-07-06 15:03 EDT, Mika Kuusela
no flags Details
Screenshot (53.40 KB, image/png)
2010-07-06 15:39 EDT, Mika Kuusela
no flags Details

  None (edit)
Description Mika Kuusela 2010-07-06 15:03:54 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: eekboard
component: eekboard
crash_function: do_row
executable: /usr/bin/eekboard
global_uuid: a377bffaa3624dd28c74e804498dd47b1c88cee0
kernel: 2.6.33.5-124.fc13.x86_64
package: eekboard-0.0.4-1.fc13
rating: 4
reason: Process /usr/bin/eekboard was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

How to reproduce
-----
1. Install eekboard from updates-testing repository
2. Start eekboard from Applications -> Accessories -> Eekboard
3. Crashes instantly
Comment 1 Mika Kuusela 2010-07-06 15:03:58 EDT
Created attachment 429861 [details]
File: backtrace
Comment 2 Mika Kuusela 2010-07-06 15:39:21 EDT
Okay, I found out that eekboard does start when using the default nouveau graphics drivers and disabling compiz, but it's still unusable since I'm unable to select a keyboard layout. With mesa-dri-drivers-experimental-7.8.1-6.fc13.x86_64 and compiz-0.8.6-1.fc13.x86_64 enabled, it crashes instantly.

[mku@eiseri ~]$ lspci |grep VGA
01:00.0 VGA compatible controller: nVidia Corporation G72M [Quadro NVS 110M/GeForce Go 7300] (rev a1)

[mku@eiseri ~]$ rpm -q xorg-x11-drv-nouveau
xorg-x11-drv-nouveau-0.0.16-7.20100423git13c1043.fc13.x86_64

I will attach a screenshot of eekboard (default nouveau driver, compiz disabled).
Comment 3 Mika Kuusela 2010-07-06 15:39:35 EDT
Created attachment 429869 [details]
Screenshot
Comment 4 Daiki Ueno 2010-07-06 21:16:32 EDT
Yeah, then probably we should disable Clutter for the package anyway.
I'll soon push the new package but for the time being you can try EEKBOARD_DISABLE_CLUTTER=1 eekboard.

BTW, other Clutter applications (such as gnome-shell) are working on nouveau with/without compiz enabled?
Comment 5 Mika Kuusela 2010-07-07 11:31:31 EDT
Did some more testing.

With out-of-the-box F13 config (default nouveau, no graphics acceleration, no desktop compositing), eekboard starts but is unusable, as shown on the previously attached screenshot. gnome-shell cannot be used since the Desktop Effects tool exits with a message notifying that no graphics acceleration is available.

Same configuration, using the 'EEKBOARD_DISABLE_CLUTTER=1 eekboard' command does the trick, eekboard starts and works properly.

Running mesa-dri-drivers-experimental-7.8.1-6.fc13.x86_64 from fedora repo, eekboard crashes instantly, with and without compiz. Trying to switch to gnome-shell results in a mutter crash.

Then, with mesa-dri-drivers-experimental-7.9-0.2.fc14.x86_64 from rawhide, eekboard does start and work properly, both with and without compiz. Switching to gnome-shell works too, but there are odd graphics artifacts on the icons.
Comment 6 Fedora Update System 2010-07-14 02:23:42 EDT
eekboard-0.0.4-2.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/eekboard-0.0.4-2.fc13
Comment 7 Fedora Update System 2010-07-14 19:05:05 EDT
eekboard-0.0.4-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eekboard'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/eekboard-0.0.4-2.fc13
Comment 8 Fedora Update System 2010-07-30 04:46:09 EDT
eekboard-0.0.4-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.