Bug 61190 - Keyboard & Mouse Freeze in Gnome with 2.4.9 Kernel
Keyboard & Mouse Freeze in Gnome with 2.4.9 Kernel
Status: CLOSED DUPLICATE of bug 57564
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-03-14 22:24 EST by Greg Smith
Modified: 2007-04-18 12:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-03-14 22:24:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Greg Smith 2002-03-14 22:24:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020311

Description of problem:
I'll be working in Gnome and everything will be working perfectly well (no slow
downs or other glitches) when suddenly my mouse and keyboard freeze completely.
This may happen after only 3 or 4 minutes or after as much as 45 minutes. I am
not even able to do a crtl-alt-backspace to kill X. The only thing I can do is a
hardware reboot.

I had recently upgraded to RH 7.2 from RH 7.1 and then up2dated my kernel from
2.4.7-10 to 2.4.9-31 when I noticed this problem. I'm pretty sure it is Gnome
dependent, but not positive. When I reboot and select the 2.4.7-10 kernel it
does not happen.

My system is:
Pogo Altura with a 1000 Mhz Thunderbird CPU, 
ASUS A7Pro Motherboard, 
256MB PC133 SDRAM (Micron),
Logitech Cordless Keyboard (installed as generic)
Logitech Cordless Mouse (nstalled as generic 3-button mouse)
Elsa GeForce2 MX 32MB AGPP Video Card

I found several other people with similar problems on a usenet search.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.On hardware like mine upgrade to (or install?) Red Hat 7.2.
2.Run up2date to get everything including the 2.4.9-31 kernel.
3.Reboot with the 2.4.9-31 kernel.
4.Login with the Gnome desktop.
5. Work away as you normally would, editing files, checking mail, surfing the
web, whatever. You should see the system freeze within 1 hour. Often it will
freeze up within the first 15 minutes.

Actual Results:  The mouse cursor is visble, but will not move. Mouse buttons
have no effect. The keyboard has no effect. Ctl-alt-backspace does not work.

Expected Results:  Obviously the mouse and keyboard should not have frozen.

Additional info:

I looked in /var/log/messages for something that might explain the hangups. I
was especially looking for something immediately before a restart that did not
follow a normal shutdown. I didn't see anything that told me what was going on.

It doesn't appear to be a problem in KDE.
Comment 1 Greg Smith 2002-03-18 11:44:48 EST
This appears to be the same as bug # 57564. I also have a SoundBlaster Live
card. Switching to the emu10k1_new driver in my /etc/modules.conf file did fix
the problem in Gnome when booting kernel 2.4.9-31. Unfortunately, it also caused
the following problems:

1. I am unable to reboot with the kernel 2.4.7-10 kernel unless I change my
/etc/modules.conf file back to use the emu10k1 driver.

2. The new driver crashes sometimes in KDE. It does not freeze the keyboard and
mouse. It just crashes the sound driver and assigns the sound output to the null
device, so I don't get any sound.

Since I use KDE most of the time, I have elected to stick with kernel-2.4.7-10
until you fix the SoundBlaster-Live/Gnome/keyboard&mouse-freeze problem in a
future kernel upgrade. The fix should:

a. prevent the mouse & keyboard from locking up in Gnome
b. not crash the sound driver in KDE
c. not require a different /etc/modules.conf file from the 2.4.7-10 kernel

You can combine this bug with # 57564.

*** This bug has been marked as a duplicate of 57564 ***

Note You need to log in before you can comment on or make changes to this bug.