Bug 611918 - Yum fails, apparently during background activity. Automatic window asks for bug report to be filed.
Yum fails, apparently during background activity. Automatic window asks for ...
Status: CLOSED DUPLICATE of bug 600677
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 16:32 EDT by Paul Johnson
Modified: 2014-01-21 18:15 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-07 07:50:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing error window. (200.25 KB, image/png)
2010-07-07 02:55 EDT, Paul Johnson
no flags Details

  None (edit)
Description Paul Johnson 2010-07-06 16:32:12 EDT
Description of problem:

Every so often a window pops up with a Python stack trace, asking for the bug to be reported.

Version-Release number of selected component (if applicable):


How reproducible:
Reliably.

Steps to Reproduce:
Start up "Add/Remove Software" or "Software Update" from the System Administration menu.

It also happens unpredictably while I am doing other things.

  
Actual results:

Window pops up containing stack trace.


Expected results:

Package manager works.

Additional info:

uname -a output:

Linux eiffel.house 2.6.33.5-124.fc13.x86_64 #1 SMP Fri Jun 11 09:38:12 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

yum list yum (to try to get version number) says:

Error: Cannot retrieve repository metadata (repomd.xml) for repository: InstallMedia. Please verify its path and try again

Maybe this is because I ran the update from Fedora 12 from the DVD to get over the /boot disk space problem.

Stack trace text is:

Error Type: <type 'exceptions.ValueError'>
Error Value: invalid literal for int() with base 10: 'ALL'
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3398, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3395, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 723, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.6/site-packages/packagekit/backend.py, line 606, in dispatch_command
    self.get_distro_upgrades()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2482, in get_distro_upgrades
    self._check_init()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2971, in _check_init
    root = self.yumbase._media_find_root(repo.mediaid)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3301, in _media_find_root
    disc_number_tmp = int(lines[3].strip())
Comment 1 seth vidal 2010-07-06 16:52:26 EDT
Can you get a screenshot of what you're seeing?
Comment 2 Paul Johnson 2010-07-07 02:55:46 EDT
Created attachment 429971 [details]
Screenshot showing error window.

Here is the requested screenshot.  The error window pops up immediately after the "Add/Remove Software" window.  It starts smaller and without the details shown.  I've clicked on "More details" and expanded the window to show the whole thing.
Comment 3 Richard Hughes 2010-07-07 07:50:09 EDT

*** This bug has been marked as a duplicate of bug 600677 ***

Note You need to log in before you can comment on or make changes to this bug.