Bug 611940 - remove unnecessary deps in all the pom.xml that needed javac workaround
remove unnecessary deps in all the pom.xml that needed javac workaround
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Build System (Show other bugs)
3.0.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: John Sanda
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-06 17:54 EDT by John Mazzitelli
Modified: 2014-06-02 15:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 15:06:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2010-07-06 17:54:05 EDT
In many of our pom.xml files, we have this:

      <!-- TODO: This is a fix for the Javac bug requiring annotations to be
           available when compiling dependent classes. It is fixed in JDK 6 -->

Some of our dependencies didn't need to be there, but because there is a a bug in the JDK5 compiler, it needed jars just to load in annotation classes. JDK6 doesn't have this problem.

We should go through and remove all those unnecessary deps.
Comment 1 Jay Shaughnessy 2014-06-02 15:06:46 EDT
done

Note You need to log in before you can comment on or make changes to this bug.