Bug 612009 - RFE: Website -- Include redirects to all installed languages
Summary: RFE: Website -- Include redirects to all installed languages
Status: CLOSED ERRATA
Alias: None
Product: Publican
Classification: Community
Component: publican   
(Show other bugs)
Version: 1.6
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Fearn 🐞
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 02:33 UTC by Ruediger Landmann
Modified: 2010-11-24 04:19 UTC (History)
4 users (show)

Fixed In Version: publican-2.2-0.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-08 20:42:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ruediger Landmann 2010-07-07 02:33:45 UTC
Description of problem:
Publican-generated websites include an index.html page that redirects visitors to localised versions of the home page. At the moment, only a limited group of hard-coded languages are supported. Publican should generate redirects for every language published on the site

Version-Release number of selected component (if applicable):
2.1

How reproducible:
100%

Steps to Reproduce:
1. Generate a website with the "create_site" command
2. Look in index.html
3. look for the line that starts: var locales = 
  
Actual results:
Fixed list of languages

Expected results:
List of languages updated to reflect site content.

Additional info:
The workaround is to hand-edit the index.html file. You need to make the same change any time you run "update_site" because this command rewrites the file.

Comment 1 Jeff Fearn 🐞 2010-08-06 03:07:56 UTC
Added template and code to regenerate this file when the tocs are updated.

Fixed in build: 2.1-0%{?dist}.t23

Comment 2 Ruediger Landmann 2010-08-06 05:24:54 UTC
Verified in 2.1.t26 -- locales match the installed languages.

Comment 3 Fedora Update System 2010-10-06 05:48:49 UTC
publican-2.2-0.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc13

Comment 4 Fedora Update System 2010-10-06 05:50:07 UTC
publican-2.2-0.fc12 has been submitted as an update for Fedora 12.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc12

Comment 5 Fedora Update System 2010-10-06 05:50:10 UTC
publican-2.2-0.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/publican-2.2-0.fc14

Comment 6 Fedora Update System 2010-10-08 20:40:15 UTC
publican-2.2-0.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.