Bug 61203 - mount umask option octal number
Summary: mount umask option octal number
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mount   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-15 12:32 UTC by Need Real Name
Modified: 2007-04-18 16:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-15 12:32:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-03-15 12:32:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020313

Description of problem:
The manual page lacks the information,
that you need to add a leading 0 to the octal umask option value.

Version-Release number of selected component (if applicable): mount-2.11b-3


How reproducible:
Always

Steps to Reproduce:
1. mount -t ntfs -orw,umask=222 /dev/hda1 /mnt/win
2. ls -l /mnt/win


Actual Results:  The umask octal value is 366, because 222 gets interpreted dezimal.


Expected Results:  dunno, but the manualpage should state that you'll need to
start the number with 0 to get expected result.

Comment 1 Elliot Lee 2002-03-27 19:31:16 UTC
The entries for most of the filesystems already specify that the values for
umask or modes must be in octal, which implies a leading zero. I will add notes
to the ntfs filesystem and any others that are missing.


Note You need to log in before you can comment on or make changes to this bug.