Bug 612036 - Lot of "btrfs bad tree block start" Errors
Summary: Lot of "btrfs bad tree block start" Errors
Status: CLOSED DUPLICATE of bug 605757
Alias: None
Product: Fedora
Classification: Fedora
Component: btrfs-progs   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Josef Bacik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-07 05:53 UTC by Michael Hagmann
Modified: 2010-08-29 16:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-29 16:34:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport KVM Host with the errors (578.31 KB, application/x-xz)
2010-07-07 05:53 UTC, Michael Hagmann
no flags Details
sosreport KVM Host with the errors ( all options enabled ) (610.26 KB, application/x-xz)
2010-07-07 05:58 UTC, Michael Hagmann
no flags Details

Description Michael Hagmann 2010-07-07 05:53:25 UTC
Created attachment 429963 [details]
sosreport KVM Host with the errors

Description of problem:

After a fresh installation with some kvm guests on Fedora 13 and one Debian Lenny

I copyed in the Fedora13 Guest on a separate xfs lvm-volume handover to the guests, then the errors starts 

Version-Release number of selected component (if applicable):

see sosreport

How reproducible:

?

Steps to Reproduce:
1.
2.
3.
  
Actual results:

KVM Guests are frozen

Expected results:

non


Additional info:

Comment 1 Michael Hagmann 2010-07-07 05:58:31 UTC
Created attachment 429965 [details]
sosreport KVM Host with the errors ( all options enabled )

sosreport KVM Host with the errors ( all options enabled )

Comment 2 Josef Bacik 2010-07-07 12:55:22 UTC
Jul  5 00:57:08 enif kernel: sd 6:0:1:0: [sdb] Device not ready
Jul  5 00:57:08 enif kernel: sd 6:0:1:0: [sdb] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Jul  5 00:57:08 enif kernel: sd 6:0:1:0: [sdb] Sense Key : Not Ready [current]
Jul  5 00:57:08 enif kernel: sd 6:0:1:0: [sdb] Add. Sense: Logical unit not ready, cause not reportable
Jul  5 00:57:08 enif kernel: sd 6:0:1:0: [sdb] CDB: Write(10): 2a 00 3e 86 31 ff 00 00 18 00
Jul  5 00:57:08 enif kernel: end_request: I/O error, dev sdb, sector 1048982015

and then it looks like you had an unclean shutdown.  This is the partition with your kvm vm's on it I assume, the fs was corrupted.  You'll have to reformat.

Comment 3 Michael Hagmann 2010-07-07 19:53:18 UTC
Hi Josef

one question, why the FS don't handle that kind of error ? Is that development not yet done ?

When the problem occured I wrote with a rsync on a xfs FS that had not a such severe Problem. I could fix it with xfsrepair.

thanks for your explanation. 
Mike

Comment 4 Josef Bacik 2010-07-07 20:07:48 UTC
Yeah basically.  Alot of the error handling code hasn't been completed (we just do BUG_ON() if we run into an error) or it hasn't been tested very well.  We're more focusing on features and stability.  It is definitely something that needs to be worked on, but there are a lot of parts of btrfs that are in that state :).

Comment 5 Michael Hagmann 2010-07-07 20:28:21 UTC
Josef

could you use my corrupted diskimage ? or could I provide more Information before I wipe out the date ?

thanks Mike

Comment 6 Josef Bacik 2010-07-07 20:48:19 UTC
Mike,

I can't do anything with it, but Yan may need it.  Go ahead and use btrfs-image to save an image, it has a compression option that you can use, and it doesn't save the data, it just saves the metadata.  Then send an email to linux-btrfs@vger.kernel.org explaining what you did and the errors you got and point to where somebody can download the image.  If Yan can use it he will pull it down.  Thanks,

Josef

Comment 7 Michael Hagmann 2010-07-07 21:15:09 UTC
Ok

thanks mike

Comment 8 Michael Hagmann 2010-07-13 20:29:44 UTC
hi Josef

sorry but the btrfs-image crashed

[root@enif data1]# btrfs-image /dev/mapper/vg_local-lv_virt Bugzilla612036-2.img
Segmentation fault
[root@enif data1]# 


I could only do a dd, does that also help?

thanks Mike

Comment 9 Michael Hagmann 2010-08-29 16:34:10 UTC
Just for Info

this bug was triggerd because of the disk where not 100% compatible with the 3ware controller 9690SA ( have to fix the linkspeed to 1.5 GB ) and there is a bug in the virtio driver for fs over 2 TB

https://bugzilla.redhat.com/show_bug.cgi?id=605757


whith the errata and the linkspeed fix, the problem is gone.

Michael

*** This bug has been marked as a duplicate of bug 605757 ***


Note You need to log in before you can comment on or make changes to this bug.