Bug 612105 - Summary: SELinux is preventing /usr/libexec/gnome-settings-daemon "setattr" access to /var/cache/fontconfig. Detailed Description: SELinux denied access requested by gnome-settings-. /var/cache/fontconfig may be a mislabeled. /var/cache/fontconfig def
Summary: SELinux is preventing /usr/libexec/gnome-settings-daemon "setattr" ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 06:32 EDT by Derek Nelson-Wills
Modified: 2010-08-19 21:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: selinux-policy-3.6.32-120.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-19 21:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Nelson-Wills 2010-07-07 06:32:08 EDT
Summary:

SELinux is preventing /usr/libexec/gnome-settings-daemon "setattr" access to
/var/cache/fontconfig.

Detailed Description:

SELinux denied access requested by gnome-settings-. /var/cache/fontconfig may be
a mislabeled. /var/cache/fontconfig default SELinux type is fonts_cache_t, but
its current type is fonts_t. Changing this file back to the default type, may
fix your problem.

File contexts can be assigned to a file in the following ways.

  * Files created in a directory receive the file context of the parent
    directory by default.
  * The SELinux policy might override the default label inherited from the
    parent directory by specifying a process running in context A which creates
    a file in a directory labeled B will instead create the file with label C.
    An example of this would be the dhcp client running with the dhclient_t type
    and creating a file in the directory /etc. This file would normally receive
    the etc_t type due to parental inheritance but instead the file is labeled
    with the net_conf_t type because the SELinux policy specifies this.
  * Users can change the file context on a file using tools such as chcon, or
    restorecon.

This file could have been mislabeled either by user error, or if an normally
confined application was run under the wrong domain.

However, this might also indicate a bug in SELinux because the file should not
have been labeled with this type.

If you believe this is a bug, please file a bug report against this package.

Allowing Access:

You can restore the default system context to this file by executing the
restorecon command. restorecon '/var/cache/fontconfig', if this file is a
directory, you can recursively restore using restorecon -R
'/var/cache/fontconfig'.

Fix Command:

/sbin/restorecon '/var/cache/fontconfig'

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:fonts_t:s0
Target Objects                /var/cache/fontconfig [ dir ]
Source                        gnome-settings-
Source Path                   /usr/libexec/gnome-settings-daemon
Port                          <Unknown>
Host                          Solent1
Source RPM Packages           gnome-settings-daemon-2.28.2-2.fc12
Target RPM Packages           fontconfig-2.8.0-1.fc12
Policy RPM                    selinux-policy-3.6.32-118.fc12
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Plugin Name                   restorecon
Host Name                     Solent1
Platform                      Linux Solent1 2.6.32.14-127.fc12.i686.PAE #1 SMP
                              Fri May 28 04:47:04 UTC 2010 i686 athlon
Alert Count                   1
First Seen                    Wed 07 Jul 2010 11:07:24 AM BST
Last Seen                     Wed 07 Jul 2010 11:07:24 AM BST
Local ID                      507e9032-45d5-4904-999d-c45dfe64d7e3
Line Numbers                  

Raw Audit Messages            

node=Solent1 type=AVC msg=audit(1278497244.452:17848): avc:  denied  { setattr } for  pid=1756 comm="gnome-settings-" name="fontconfig" dev=sdb11 ino=57237 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:fonts_t:s0 tclass=dir

node=Solent1 type=SYSCALL msg=audit(1278497244.452:17848): arch=40000003 syscall=15 success=no exit=-13 a0=9abc920 a1=1ed a2=2421a8 a3=9abc920 items=0 ppid=1754 pid=1756 auid=4294967295 uid=42 gid=477 euid=42 suid=42 fsuid=42 egid=477 sgid=477 fsgid=477 tty=(none) ses=4294967295 comm="gnome-settings-" exe="/usr/libexec/gnome-settings-daemon" subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
Comment 1 Parag Nemade 2010-07-29 02:01:37 EDT
moving this to selinux component to see if its owner can help to know how can this be fixed.
Comment 2 Daniel Walsh 2010-07-29 10:43:06 EDT
Miroslav this is fixed in F13 by changing the label, but I think we should just allow it for F12.
Comment 3 Miroslav Grepl 2010-08-05 07:50:10 EDT
Fixed in selinux-policy-3.6.32-120.fc12
Comment 4 Fedora Update System 2010-08-05 09:19:09 EDT
selinux-policy-3.6.32-120.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-120.fc12
Comment 5 Fedora Update System 2010-08-05 19:23:15 EDT
selinux-policy-3.6.32-120.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update selinux-policy'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/selinux-policy-3.6.32-120.fc12
Comment 6 Fedora Update System 2010-08-19 21:39:29 EDT
selinux-policy-3.6.32-120.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.