Bug 612181 - new maven2 requires old maven2
new maven2 requires old maven2
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: maven2 (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Yong Yang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 09:50 EDT by Anton Guda
Modified: 2010-07-12 11:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-12 11:12:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anton Guda 2010-07-07 09:50:11 EDT
Description of problem:
New maven2 requires apache-resources-bundles,
it require maven2-plugin-remote-resources from old maven2.


Version-Release number of selected component (if applicable):
new: maven2-2.2.1-7.fc14, apache-resource-bundles-2-3.fc13
old:
maven2 = 0:2.0.8-3.fc12 is needed by 
maven2-plugin-remote-resources-0:2.0.8-3.fc12.noarch

How reproducible:
Always


Steps to Reproduce:
1. Try to install maven2 and all deps from scratch.
  
Actual results:
Fail:
maven2 = 0:2.0.8-3.fc12 is needed by maven2-plugin-remote-resources-0:2.0.8-3.fc12.noarch

Expected results:
All packages installed w/o unneeded dependencies.


Additional info:
Comment 1 Stanislav Ochotnicky 2010-07-09 08:57:06 EDT
Can you post whole output from "yum install XXX", including dependency resolution part etc? Because I certainly cannot reproduce this by removing maven2. Yum removed all dependencies with it and then I could install it again without any problems. 

Plus maven2-plugin-remote-resources is obsoleted/provided by maven-remote-resources-plugin now. Can you re-try? Maybe this was caused when special koji tag was merged into rawhide and you synced your repository when not all packages were in sync...
Comment 2 Anton Guda 2010-07-12 11:12:12 EDT
Really, my local rebuilf repo was poisoned by old packages. 
It not obvious to resolve dependencies is this case manualy.

Note You need to log in before you can comment on or make changes to this bug.