Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 612259 - Own /usr/share/gdb/auto-load/{,usr/}lib{,64}
Own /usr/share/gdb/auto-load/{,usr/}lib{,64}
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-07 13:21 EDT by Jan Kratochvil
Modified: 2010-07-08 04:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 04:08:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kratochvil 2010-07-07 13:21:20 EDT
Description of problem:

F-13 gdb.rpm currently contains
/usr/share/gdb/auto-load
/usr/share/gdb/auto-load/usr
/usr/share/gdb/auto-load/usr/lib
/usr/share/gdb/auto-load/usr/lib/libstdc++.so.6.0.13-gdb.py
/usr/share/gdb/auto-load/usr/lib64
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.13-gdb.py

Since F-14 these *.py files will be in libstdc++.rpm (it is so upstream, since gcc-4.5.0 which will be in F-14).
libstdc++.rpm will not `Requires: gdb'.
libstdc++.rpm should not own:
/usr/share/gdb/auto-load/usr
/usr/share/gdb/auto-load/usr/lib
/usr/share/gdb/auto-load/usr/lib64
gdb.rpm cannot own them as it may not be installed.

filesystem.rpm owns:
/usr
/usr/lib
/usr/lib64

Therefore filesystem.rpm should own at least these directories:
/usr/share/gdb/auto-load/usr
/usr/share/gdb/auto-load/usr/lib
/usr/share/gdb/auto-load/usr/lib64
/usr/share/gdb/auto-load/lib
/usr/share/gdb/auto-load/lib64
(the last two for *.py in glib2-devel.rpm)

Version-Release number of selected component (if applicable):
F-14
Comment 1 Ondrej Vasik 2010-07-08 03:29:18 EDT
Is that really required? Filesystem should create and own basic system packages which are in use by the vast majority of users. 

If the directory is in use only by some specific group of users - in this case I assume users of gdb - so probably developers - filesystem subpackage in gdb and Requires: gdb-filesystem in packages with these python scripts makes more sense to me. This will reduce requirements for gdb and will keep filesystem hierarchy more clean...
Comment 2 Ondrej Vasik 2010-07-08 03:30:46 EDT
sorry ... I meant "Filesystem should create and own basic system directories" - of course ...
Comment 3 Jan Kratochvil 2010-07-08 04:02:09 EDT
OK, I will create gdb-filesystem.rpm, thanks for advice.

BTW /usr/lib/debug is now owned by all *-debuginfo.rpms and no one else.
Comment 4 Jan Kratochvil 2010-07-08 04:08:33 EDT
From Jakub: I think gdb-filesystem package is unnecessary.  If it is not in filesystem, let it be owned by the < dozen packages that will ever ship pretty printers.

Note You need to log in before you can comment on or make changes to this bug.